"1.000 observation" / "Eine Beobachtung"

Platform (Android, iOS, Website):
Website

Browser, if a website issue (Firefox, Chrome, etc) :
Firefox 44

URLs (aka web addresses) of any relevant observations or pages:
Currently any of my observations, e.g.
https://www.inaturalist.org/observations/59807239

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):
1observation

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
I’ve just reached exactly 1000 observations. Oddly, the German version of the website shows “Eine Beobachtung”, i.e. “One Observation”.
In the English version, I see “1.000 observation” with a missing plural-s.

There might be some number formatting issue behind the problem: the decimal separator on the european continent is a “,” while the thousands separator is a “.”, i.e. just the other way round than the americans do it. And then the decision for plural-s (or the german translation) gets made on some formatted number expecting american format…

4 Likes

Translation seems OK so I guess it you are right and it counts 1.000 as 1.
Another language translates it one on one and has the same error.

Dutch:
{%count} = 1 , see pic below
English
{%count} = 1.000 , see pic above
German
{%count} is removed from translation and ‘‘Eine’’ is added, see pic above.

1000observations

2 Likes

This is what I see in English.

Screen Shot 2020-09-18 at 11.09.54 AM

This is what I see in German.

Screen Shot 2020-09-18 at 11.11.15 AM

That’s what it should be right?

Well, you see, that’s exactly what I suspect: the comma “,” vs. dot “.” as the thousands separator or the decimal separator…
Compare “1 , 000” and “1 . 000”.

2 Likes

Is that a setting somewhere? How did you get the alternate notation?

1 Like

In Windows, that can be found some where in “Region and Language Settings” in the “Control Panel”. That “alternate” notation is standard in many places outside the US.

2 Likes

If I ONLY change the language setting to English {%count} changes from value: it was 1 and becomes 1.000. Strange that TE can change to German and gets {%count} a value of 1,000 ( with komma ;-) )

You’re dutch, aren’t you? So the use of comma vs. dot on your machine is the same as on my machine. thomaseverest is american, and there it is exactly the other way round.

1 Like

OK I think this may be a browser issue, or at least partially so. Changing the computer region (Mac) didn’t change anything for me, and neither did changing the language in Chrome (which is what my above 2 screen shots were from). However, if I switch to Firefox and change my language to German, I can replicate this.

German Firefox, German iNat:
Screenshot 2020-09-19 at 17.40.27

German Firefox, English iNat:
Screenshot 2020-09-19 at 17.44.57

Interestingly enough if I set Chrome to German and tell it to translate the English iNat site, I get this. Is that what it should be?
Screenshot 2020-09-19 at 17.28.39

What happens if you use a different browser?

FYI, this was a combination of a pluralization error and some erroneous translations. For the latter, make sure the delimiter and separator values are translated to format and pluralize numbers correctly: https://crowdin.com/translate/inaturalistweb/38/en-de?filter=basic&value=3#q=delimiter. I just changed the values for German so numbers should appear as 1.000,10 for one thousand and one tenth. I still need to deploy for this to be totally fixed, which I’ll probably do on Monday.

1 Like