Captions for the "Stats" diagram in Projects are incomplete

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: When I look at “Stats” for the above project, and focus on the pie-diagram for “Species”, the caption below for the species groups seems to be truncated. i.e. there is no caption for “Insects” yet when I hover my cursor over the red 31% it does show up as insects.

Step 2: I suspect that the block at the bottom of the page "Inappropriate content? " is taking up too much of the visible page and hiding “Insects” and perhaps some other categories.

Step 3: I think this because on my wife’s laptop I can just see about 10% of “Insects” before it is cut off.

1 Like

Pretty sure this is the same bug reported here?

FWIW I can’t replicate it in Chorme (or Firefox):

Yes, it seems to be the same bug in the link you gave.
But it doesn’t seem to be fixed, we’ve tried different zoom levels and it doesn’t change.

Also tried on MS Edge and get the same problem.

I’ve now tried it on Firefox and get about the top half of that last line “Insects Other Animals”

It changed for me when I zoomed it to 170%

It’s related to the aspect ratio and the issue is dependent on your screen resolution and aspect ratio. I get it on all my computers at all zoom levels on all browsers. The only way I can temporarily change it is to open up the “inspect” view for the page and manually make changes to the container dimensions.

Of course, that reverts back to default as soon as you refresh the page.

It should be a quick fix as all that needs to be done is to make a small change to how the ‘iconic taxa’ container is shown, but, like the issues with the text boxes obscuring the map on the ‘explore’ page (which is due to pretty much the same problem) it’s taking a long time to address.

The iNat platform was developed when people’s computers generally didn’t’ have monitors that are as high resolution as they are now and the site hasn’t been updated to take that into account.

1 Like

I’m seeing this as well and found that resizing the browser window (Firefox) may “fix” it so I assume it has something to do with how it displays in certain browsers with a certain window size.

as noted in the other thread, i think you need to increase the effective width of your browser window to replicate the problem. it looks like the width at which items on the page change scale is 1200px. below 1200px, the pie chart’s container is approx 293.3px x 330px (about 9:10 ratio). above 1200px, the container is 360px x 330px (12:11 ratio). since in the latter case, the container is relatively wider, its contents get cut off slightly at the bottom.

if your screen is effectively <1200px wide, you might not ever see the problem. to increase the effective width of your browser window, you can change the zoom in your browser or system settings. for example, if your native screen resolution is 1200px and your OS zoom is 100%, then if you change your browser zoom to 90%, then you’ll increase the effective width of your browser window to 1333px.

EDIT: actually, maybe there’s there’s something else… your charts look like they are scaled such that the bottom contents should have been cut off slightly. so maybe MacOS scales things slightly differently somehow. or maybe fonts…