Need info! iOS app crashes when you tap on photo library icon in iOS 13

Hello. My iphone 6S updated to ios 13.1.2 yesterday, and I could no longer upload photos into iNaturalist. I would tap on the photo to be uploaded in my photo library, press “done” and the app would crash and close. I am (hopefully) attaching screenshots as requested. After reading the other posts, I did try to upload again after editing the photo. I made no changes to the photo other than turning it around a full 360 degrees, and lo and behold, the app did not crash and accepted the photo! iNaturalist is the best app ever and I use it all the time. Thank you for the app and for whatever fix you are able to provide. Have a lovely day!!

I am a new user, and the forum would only allow me to upload one photo per reply. Here is the other screenshot.

screen%20shot%20for%20iNaturalist%20%232

Do you have your iCloud set to keep original photos?

Hey all, I think we’re good for information now, thanks for sharing! We’re just working on implementing a fix, testing it, then getting out to the app store.

If you absolutely need to get observations up in the meantime, you can use our web uploader on a laptop or desktop computer. Here’s a tutorial video for it: https://www.inaturalist.org/pages/video+tutorials#add_web

2 Likes

I just saw the update released on the app store. Downloaded it and still not working. The app still crashes when trying to access the photo library in iOS. Running the latest version of iOS and the latest (as of today) version of iNaturalist. Tried a complete re-install and still no-go.

If you guys need real-world users to help beta test a solution, let me know.

The only one I see is for Seek, iNaturalist is still on 2.8

1 Like

I update to iOS 13.1.2 on my iPhone SE a few weeks ago and experience the app crashing but after I selected the photos in the library & hit “done”. It appears to crash if I select photos taken prior to the upgrade.

image Crazy this just started this morning
I’m running 13.1 but it wasn’t a issue yesterday
Anytime I hit the photo button to up load a photo it crashes

Crazy on my phone all I need to do is hit the Camera button and it crashes on my tablet it can hit the button and it will open my photos
But when I select the photos and then I try to upload it crashes
Again I had no issues yesterday it started this morning
I’m running 13.12

Crazy but now it working so it’s not the App ???

Is your app updated to v3.8? That’s what I have. It says the latest update was 1 month ago. Still not working for me. Support said an update could come last week but it hasn’t arrived for me.

I can use seek to upload an observation with a single image. As an aside, seek crashes when I press on a species image from the home menu.

This is my current work around as well. I submit the ID and photo using Seek (via Camera Roll). Then I do any ID-related edits in iNaturalist. Slow, and you can only submit a single image, but it’ll do until this gets sorted.

2 Likes

Seek Version 2.3.4 update (10/15/19) is stable no complaints anymore!

2 Likes

Ok I just updated to IOS 13.1.3
And the crashing issue is back while pushing
The camera button on the INat app
The issue I had Sunday morning
Faded away by Sunday afternoon
Is back after the update

@tiwane
Nothing is working now
On the phone since updating to 13.1.3
The tablet running 13.1.2 has started crashing again to when hitting and camera icon again
I off loaded the app on both and reload same result plus I did a reboot of the iPhone still same result a total of 6 of us up here are having the same issues…
As stated above Sunday morning it was doing this then Sunday afternoon it was working fine

1 Like

@ck2az would you be willing to beta test? If so, please send me a message here on the forum or in email (alex@inaturalist.org) and I’ll get you a beta release that I believe will fix this problem.

And I’m able to upload again

I sent you a email

Still experiencing the crash. My settings all set to Russian, but my settings are identical to the ones uploaded.