Seek app can’t access photo library on iphone

I’m sorry about this - no one on the iNat team are able to replicate this issue on our devices, so it’s really difficult to investigate. A workaround right now is to change Seek’s Photos permission to “Selected Photos”.

What we need are as many details as possible:

  • how many photos are in your device’s Photo library?

  • which version of iOS is your device running?

  • which version of Seek do you have?

  • are you using iCloud backup?

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (iOS,):

*App version number Seek Version 2.15.0

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Open Seek

Step 2: Click on Camera, click continue

Step 3: Select Photos, goes to white screen and never shows photos.

Thanks for the bug report, I’ve moved your post to the existing topic.

  • about how many images do you have in your library?

  • do you use iCloud backup?

  • does changing Seek’s Photos permission to “Selected Photos” work as a workaround?

I am also having this issue.

I have 10,585 photos in my photo library along with 332 videos. I am running iOS 16.6. I am running Seek App version: 2.15.0 (310). I am using iCloud Backup. Changing Seek’s Photos permission to “Selected Photos” does work as a temporary workaround. This seems to have started fairly recently, though I can’t say exactly when.

2 Likes

Are these settings available on the free app? I don’t find any settings except a couple of toggle switches: display names, automatically take a picture, and display seasonality.

I did find my own workaround since I don’t seem to have the same settings. I sent the photo to my laptop and then took a new photo of it.

Seek is completely free, there are no other versions of Seek (or of iNaturalist).

Permissions for apps (eg location access, camera access, etc) are controlled at the device’s system level both both iOS and Android. Which device are you using?

I’m having a similar issue and only have “None” and “Add photos only” as options. Shouldn’t there be an “All photos” option?


This is definitely a bug, I’m sorry it’s affecting you.

  • which device are you using?

  • which version of iOS is it running?

  • did you just install Seek, or have you had Seek installed for a while?

I’m also having this issue. It occurred when I installed the app and denied Seek access to my iOS photo library on the first launch.

When I try to change the setting to allow access to my photos, the only options I have for photo library access are: “None” and “Add Photos Only”.

I’m using an iPhone 14 Pro Max and running iOS 17.5.1.

I’ve tried reinstalling the app but that doesn’t fix the issue or give me any other options in iOS for photo library access.