Species fails to appear in search of place

Platform (Android, iOS, Website): website

Browser, if a website issue (Firefox, Chrome, etc) : opera

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/places/australia#q=veronica%2Bpersica

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I’m systematically adding establishment means = introduced for all the common non-native weeds in Australia that haven’t been tagged as such yet.

Step 2: No matter what I search for on the Australia place page, I cannot get Veronica persica to appear, despite there being 150 observations of it.

Step 3: I’ve tried ‘Veronica persica’, ‘Veronica’ and ‘persica’, but none work

Step 4: This has happened to me for multiple other species too, but searching for the genus only made them appear (unlike this case)

Ok, so I can get it to appear by searching for ‘speedwell’, but I still don’t see why the other searches shouldn’t work

perhaps even more bizarrely, each time you search the same thing, it doesn’t even provide consistent results. My screenshot in my first post shows results from searching ‘Veronica persica’

I just clicked that exact same URL, and now I get this, with two species having dropped off the search, despite the search term being exactly the same:

can’t get Lotus suaveolens to appear at all now, no matter what I search

I can confirm that I also cannot get Veronica persica to show up unless I go to the actual checklist page and search from there (https://www.inaturalist.org/check_lists/7060-Australia-Check-List?q=Veronica+persica)

As for Lotus suaveolens is it not showing up because there are no research grade observations (yet) in Australia? I can only find your observations Thomas and they’re not RG (yet). I don’t know how the checklists work, but I’m just throwing this out there as a potential reason for the species not being in the checklist

I just went to key out one of your Lotus suaveolens observations using PlantNET and it seems to key out to Lotus subbiflorus


Lotus suaveolens seems to be a synonym (see link above and also POWO) but I am unfamiliar with the species so am not sure; even though they key out to subbiflorus I’m not familiar with it at all and might be misinterpreting a character or couplet in the key

1 Like

yeah suaveolens needs to be swapped to subbiflorus on iNat (see https://www.inaturalist.org/flags/497333), and I have this down as subbiflorus in my own off-iNat list

actually I think this could be it, I just checked a few other random species I’ve seen that I know have zero RG obs yet for Australia, and they don’t show either

If you want to swap that one I’ll support the ID because even though I’ve never seen the species I just keyed it out again using a different key with the same result. So I’m more confident now with the ID. That will at least determine whether it’s missing from the checklist because none are RG

1 Like

As for Veronica persica being missing, that’s weird

if this is confirmed as the case, I’ll make a feature request to change this, as it means (to my knowledge) I can’t mark anything as introduced if it only has Needs ID observations

1 Like

there is a dodgy workaround to this; if you agree with an ID to make an ob RG, it will appear on the place page, you can add the establishment means, and then if you delete your ID and the ob goes back to Needs ID, the establishment means remains

Yeah, I think the feature request might be the better way to go :) Although, can’t you add species manually anyway (I can’t recall, it’s been a long time since I really worked with the checklists)?

as an update to this, this doesn’t work. The introduced status attaches for a little while, and indeed ‘sticks’ after you delete the ID, but then it disappears (after how long, I have no idea, I only checked now)

I cannot get Lilium formosanum to appear in searches, despite it having RG grade Australian observations (EDIT: I manually added it, so it does appear now, but it should have appeared without me having to do that)