Can't ID or comment

When I tried to make a suggested ID I can’t and I see the “log in or sign up” note in the ID box. When I go to the log in window I see that I am already logged in. When I go back to the un-identified observation I still can’t comment, even after repeated tries.
What am I doing wrong? (

Can you please share a screenshot of what you’re seeing? Here are instructions for how to take a screenshot on several types of devices:

Is this only happening for that observation, or any observation?

No I can’t… now it works.
But what was wrong? I tried to log in, but I was already logged in, but couldn’t make a comment or ID. Now I can (see

1 Like

I’ve had an experience like that when I am logged into iNaturalist, but follow a link which is for one of the regional versions, such as iNat Australia or Canada. Is that possibly what happened to you?

When that happens, how do you get to the correponding page of the regular iNaturalist?

Edit the first part of the url up to “.org” or however it ends

I usually don’t bother trying to comment or ID! But yes, you can edit the URL.

For iNaturalistAu observations, the url has an “.ala” in it that you have to remove, as well as the “.au” at the end.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.