Desktop webpage not accessible via T-Mobile in Poland - resolved itself

Platform : Website

Browser: Firefox, Chrome

Description of problem:

All pages on iNaturalist on any tested desktop browser show HTTP 404 Not found response. The page works fine on a smartphone from the same IP address. The forum works normally.

edit: found the core of the problem - the smartphone was NOT connected to the WiFi. The problem is indeed network-specific, everything on iNaturalist works fine using cellular data through the Play network (I am in Poland), nothing works when using the local network connected through an LTE router to T-mobile cellular network - but the problem seems to be restricted to iNaturalist, the rest of the internet works fine.

edit2: It’s a DNS problem. T-Mobile’s DNS resolves to something else than Play’s. Using Google DNS on the T-Mobile connection solves the problem. Probably there was a change of connection on iNaturalist’s side and it has not propagated yet.

edit3: Indeed, problem resolved itself today. It was just an interesting coincidence that a stale DNS did not read to an outright refusal of connection, but to 404.

I can’t replicate this, the site is working perfectly fine for me. Have you tried again since then?

Yes, the problem persist right now. etc… any page tried from history, they all give 404 on my computer, the same in incognito and different browser, the same after refreshing and ctrl+f5.

edit: also, the same from my wife’s computer - still the same network (but that’s the smartphone using the same wifi as well), but win 7 vs. win 10. It just doesn’t seem to be a local software issue.

Can you try using a different Internet connection?

It seemed pointless, but I tried it using the cellular data, the result confused the hell out of me and then I noticed that I have accidentally switched off the WiFi on my smartphone before.

So it’s the connection - it does NOT work on smartphone when on the home network and it DOES work on computer when connected to cellular data. Which is pretty silly, because the home network IS cellular data anyway, but it’s T-Mobile, while the smartphone is on Play (I am in Poland).

I will edit the bug report accordingly. It’s still a problem!

1 Like

The problem was related to the fact that both networks resolve “” to a different IP - the bad one (T-Mobile) resolves to, while the good one (Play) to The problem is thus resolved by switching from the network-provided DNS server to Google’s - which I would prefer not doing, but it is a fix for now.

I vaguely remember some problems about 15 years ago connecting to some sites on a laptop via T Moblie (when it was still called T Mobile in the UK).

I think it was something to do with them using a proxy server. They also used data compression to save bandwidth, which screwed up the layout on some sites.

More recently there have been problems to do with T Mobile and other operators switching to IPv6 only addresses.

Problem resolved itself, probably due to DNS propagation.