I'm getting no pics!

Is it just me? My iNat’s been unusable for the past 2 mornings - I’m getting no pictures, except the posters’ ID tags. No matter how many times I refresh the page. Normal Windows desktop version. Help please! I get grumpy without my regular morning iNat fix …

It’s acting fine here. Maybe some oddball internet or local network problem? Do other sites all seem to work? Have you tried rebooting? Do you have other computers/devices on the same network that you can try it on?

It’s almost impossible to diagnose an issue without specific details. Can you please share some screenshots of what what you’re seeing? Instructions can be found at: https://forum.inaturalist.org/t/about-the-bug-reports-category/60

It would also be helpful to know which browser you are using, and whether anything changed with your network (eg router, internet service provider, etc) around the time this started.

Is it affecting other sites you visit? I find it helpful to see if another site I use is showing any sign of problem or slow connection, which can help rule out network issues.

Same here.

Thanks all for suggestions.
Nothing’s changed - except the winter school holidays have started on Friday, when my troubles began, and my town is inundated with holidaymakers, possibly overloading the 3G network?
But - all my other usual sites are opening & showing normally: it’s only the iNat pics that won’t load! Still!
I’m using Chrome on Win7. Diagnostics on our Wifi router show its acting normally.
I’ll attempt to attach a screenshot of my iNat homepage so you see what I see …


No Tiwane, I can’t see it. Just get this error message:

Tiwane, I’ve now tried (klunky) Explorer - and still get no pics …

A post was split to a new topic: Android - Observations List does not show thumbnail images

@bushboy - unfortunately that screenshot shows the page’s elements, not the console. Maybe those instructions are outdated… You’ll need to click on “Console” (see red arrow):

Then take the screenshot.

Our images are hosted on Amazon Web Services, and the fact that you can’t see the image itself (in screen cap 2) makes me think that something is impeding you from accessing files on Amazon Web Services.

@riodelmartians - this thread is about bushboy’s inability to see images on iNaturalist’s website. Your issue seems unrelated so I’m going to move it to a different thread.

Oh, sorry. Here it is:

I’d be curious to know if this is an issue when only on a certain network. If you use cellular data on your phone or use the internet in a cafe, can you load the images?

@bushboy are you able to load this? https://s3.amazonaws.com/static.inaturalist.org/photos/42254319/small.jpg

@tiwane Yes! Pops up almost instantly!

1 Like

@tiwane On my iPhone the pics won’t load either - the thumbnails are blank and I just just get an interminable turning wheel when I try to open the Obs’ image(s). But then my phone and laptop are both on the same network, Telkom - a South African ISP that works best in our small town.
I haven’t tried an Internet cafe …

1 Like

Thank you for the info @bushboy, I think it might help us narrow this down.

1 Like

Is it possibly my poor upload speed? These numbers vary tremendously each time I try the test, not at all sure they’re meaningful …

Unless there are many others in South Africa (or other countries) who are experiencing something similar, we think it’s likely due to a firewall or some other blocker in your internet stream that is blocking static.inaturalist.org, which is where our photos are accessed on the site. Otherwise, you likely would not have been able to load https://s3.amazonaws.com/static.inaturalist.org/photos/42254319/small.jpg quickly.

So if anyone else is not able to load photos from iNaturalist, please let us know.

Sorted! Reset my DNS protocol per https://www.lifewire.com/how-to-change-dns-servers-in-windows-2626242 and suddenly I have pics again! Glorious: it’s been a long cold winter…
Why it happened I have no clue.
Thanks all - Tiwane in particular!