Bug: iOS app problems with location when identifying on airplane

Platform iOS

Screenshots of what you are seeing

available on request via email. I tried uploading them here but the web form doesn’t accept it for some reason.

Location Fetch Error The operation couldn’t be completed.
(kCLErrorDomain error 0.)

Description of problem

I recently decided to kill some time on a flight with WiFi by identifying some critters on my iPhone. I was in airplane mode but WiFi was active and available I was constantly bombarded in the app with warnings about not being able to find my location. I don’t know exactly why this happened, but the iNaturalist iOS app should be robust against failures to find a location. It doesn’t need this info when I’m identifying, not observing.

Note that I could usually proceed and identify one organism but I’d see the popup on the next, usually when trying to filter to a named location or scrolling. That is, the app was functional but I was constantly interrupted by unactionable error dialogs.

What should happen:

Ideally iNaturalist should know when the location isn’t available and not ask. However if it does, it should fail more gracefully. It certainly shouldn’t pop up dialogs like this more than once.

I usually keep my device in airplane with wifi on most of the day when at home and I haven’t encountered this. I just tried now with airplane mode on and location permissions off for iNaturalist and only encountered that pop-up once. This is using the current release, 3.2.6, build 670, on my iPhone 13 Pro running iOS 16.2.

  • if you do the same thing while not on an airplane, are you able to replicate it?

  • if you still have the screenshots, you can email them to help@inaturalist.org

I sent the screenshot. So far I am not able to replicate this in airplane mode when connected via my home WiFi. FWIW this happened on JetBlue FlyFi. I’m just guessing now, but it’s possible that either or both of these is true:

  • GPS works in the iPhone on the ground but not in the air.
  • My WiFi network is recognized and mapped to a location, but FlyFi is not.
1 Like

You’re correct, this is the appropriate and intended behavior. It’s obviously not working correctly, so I’ll take a look next week and see if I can improve things. Thanks for the bug report!