Can't Add New Names through "Search external name providers"

It seems like it’s just been disabled, but I see no news about this.

Desktop: Chrome and Firefox both attempted. After I add a suggestion, it simply hangs at “Loading…” Normally it would either pop up a name or tell me it can’t do it. But right now it’s just getting stuck at a loading message. (see image)
App: Doesn’t do anything. Just leaves it blank and I can return to the ob, but nothing has changed.

URLs:, though I’ve tried the function on multiple obs and it’s not working for any of them.

Screenshots of what you are seeing:

Description of problem:
Just attempt to add a valid name that isn’t in the iNaturalist database. I’ve tried multiple on several observations. Right now I’m going through the sponge genus Aplysina and there are quite a few not added to the database, particularly from the eastern Pacific. Some that need added are: Aplysina clathrata, Aplysina revillagigeda and Aplysina encarnacionae:

In the meantime, create a flag on the genus to get a curator to add the species manually

1 Like

I just tried to visit WoRMS and it’s down for maintenance. That can’t be coincidence.

Hmm. WoRMS is back up, but behavior remains unchanged.

I notice I did misspell “revillagidedi”, but it doesn’t change the behavior when I spell it correctly or try any other names not in the database. Also, trying to view the flag is throwing up an error message.

Searching external name providers should work properly now. If you continue to have problems could you please post the names that never get past “Loading…”

Cool. Now it’s failing in the correct manner instead of the wrong one lol.

Thanks, @pleary.

It’s doing it again : /

Occurs with Spheciospongia purpurea too

Thanks for sharing the name that was failing for your. With that extra info I was able to track down another bug which should be fixed now. If anyone else sees this problem again, could you please post the names that are not loading?