Can't bulk edit fields

I’m trying to apply fields to subsets of my Observations. I can get as far as selecting the Observations, getting into Batch Edit, and filling out the Field. But when I click Apply Field, nothing happens.

Platform: Web.

Browser: Chrome Version 83.0.4103.116 (Official Build) (64-bit) on Windows 10

Description of problem:

Here’s a step-by-step way to reproduce the problem:

  1. I select Edit Observations for my profile: https://www.inaturalist.org/observations/xris
  2. I click Search to get to the criteria I need.
  3. For this example, I want to see for the text “on Erigeron” in the Description. The correct list of Observations is displayed: https://www.inaturalist.org/observations/xris?utf8=%E2%9C%93&q=%22on+Erigeron%22&search_on=description&quality_grade=any&reviewed=&geoprivacy=&identifications=any&captive=&place_id=&swlat=&swlng=&nelat=&nelng=&taxon_name=&taxon_id=&day=&month=&year=&order_by=observations.id&order=desc&rank=&hrank=&lrank=&taxon_ids%5B%5D=&d1=&d2=&created_on=&site=&tdate=&list_id=&filters_open=true&view=map
  4. I click Batch Edit, Select All, deselect/uncheck anything not from this year, then click Edit Selected: https://www.inaturalist.org/observations/edit/batch?o=50946425,50945058,50937641,50937523,50927584,50927550,50836765,50836683,50836583,50832938,50832824,50832751,50832595,50721152,50721082,50720927,50720802,50670970,50670866,50670796,50610797,50598793,50563850,50491499,50491236,50427029,50367604,50367532,50366544,50319561,50314108,50313821,50205525,50205430,50205108,50204769,50204689,50204328,50204285,50204254,50203817,50203709,50203418,50167518,50111823,50109365,50109310,50109103,50095972,50095820,50095478,50095379,50095339,50015389,50015019,50014949,50014882,50014750,49965466,49965339,49965290,49964643,49964530,49964407,49964216,49896448,49891448,49889649,49784201,49777847,49777577,49777515,49777370,49372987,49225748,49025681
  5. I click Batch Operations to expand the list of things to edit for all the observations.
  6. I click More Fields to show everything.
  7. Finally, I can click Add a Field. I select and fill out the Field I want.
  8. When I click Apply fields, which shows a down-arrow to apply itself to ALL the Observations, nothing happens to any of them.

DOH! I never saw it before, because I was picking up 200 Observations at a time, but if you scroll AAAAALLLLLLLL the way down to the bottom of the list, there’s a Save All button.

At that point, it fails with the 504 Gateway Time-out problem, but that’s a different issue than “there’s no way to batch edit fields.”

2 Likes

That’s a known issue with batch editing (see here, here, here). Tony already filed a bug report for it.

1 Like