Can't find any observations for a species (Euphorbia milii) in a place even though I know there's at least one here

SUMMARY: Searching for Euphorbia milii observations in Florida produces no results even though there is at least one observation of this species in Florida.

Platform: Website

Browser: Vivaldi

URLs: https://www.inaturalist.org/taxa/162839-Euphorbia-milii/browse_photos?quality_grade=any&layout=grid&place_id=21 and https://www.inaturalist.org/observations/39665570

Screenshots of what you are seeing:

Description of problem: Searching for Euphorbia milii in the US state of Florida:
https://www.inaturalist.org/taxa/162839-Euphorbia-milii/browse_photos?quality_grade=any&layout=grid&place_id=21
…produces no results. Even though I know there exists at least one observation in Florida, namely my own: https://www.inaturalist.org/observations/39665570
(And yes, it does already say “any” for quality grade.)

Refreshing the search page does not solve the issue.

Update: also found that Euphorbia milii is not suggested as a nearby species when loading suggested IDs for an observation in Plantation, Florida:

This is happening on https://www.inaturalist.org/observations/95572968 . However, I’ll be adding that ID myself, so I don’t know how that will change things by the time someone reads this thread.

edit: After adding my ID, refreshing the search page still doesn’t bring up this observation either (though perhaps it isn’t yet properly refreshed in the database?).

Neither the taxon photo browser nor the seen nearby suggestions include cultivated observations.
Is there a reason you’re using the taxon photo browser instead of Explore?

2 Likes

if i go directly to this link (try opening in a new private browsing session), i do get results:

interestingly, at least some of these observations come from outside of Florida. it looks like the screen is effectively ignoring the place filter.

if i change the Quality Grade filter to Research, the photos all go away. interestingly, if i refresh the browser window, i get everything back again.

if i clear the Florida filter and manually reapply it, then i can’t reproduce the steps above. but then if i clear the Florida filter, i can go directly to that link again and get the same results as before.

there’s something strange with the screen beyond the behavior that was originally reported in the original post.

1 Like

Your one photo is casual grade and can be found on Explore and Identify filtered searches. I assume it doesn’t appear in taxa page photos due to either: if taxa photos never show casual (if filter=“all” means RG and needs ID), if they should but there’s some (non-bug) issue on your end or how you’re searching, or if they should but there’s some bug with filters or the page.

It’s likely the reason it’s not on the seen nearby is because all the observations in florida are cultivated.

2 Likes

Someone else posted a photo of what looked like this species, and I wanted to check the appearance of this species before posting my ID. Easiest way to do that is to bring up the species in the ID suggestions (automatically or manually by typing) and click View then click View More in the box with the photos.

That brought me to that page. Or, actually, it brings me to https://www.inaturalist.org/taxa/162839-Euphorbia-milii/browse_photos , which has the same result. I think the link I posted above is after I checked to make sure the quality filter was set to “any”, i.e. I wanted to capture observations that were casual-grade since I know this is an ornamental species.

Incidentally, when using the Explore feature, it seems that I have to remove the “Verifiable” condition in order for my observation (and many others) to show up. So maybe that’s the hangup on the taxon photo page? even though there’s not a setting for undoing that filter.

@pisum

interestingly, at least some of these observations come from outside of Florida. it looks like the screen is effectively ignoring the place filter.

I feel like I’ve run into that bug before at some point, but I don’t remember when. But that might also be why you’re getting any photos at all.

@brian_d My obs is on the Explore page but not on the Identify page that you linked.

Also I can’t find a filter thing for the taxon photos page that says ’ filter=“all” ', though this did get me to play with the observations page and find that apparently I need to turn off the “Verifiable” requirement for a bunch of E. milii observations (including my own) to show up. (I was doing this using Broward County, FL, US as the geographical criterion, for reference, as apparently that’s my default location filter despite my using the entire state of Florida for my taxon photo searches which seems to be a separately-saved thing.)

@kevinfaccenda

It’s likely the reason it’s not on the seen nearby is because all the observations in florida are cultivated.

I thought that “Quality Grade: Any” would allow those to be shown, but apparently not. It seems to me that there might be an invisible “Verifiable” filter, which would mean that no Casual observations ever get shown there no matter what other settings I set. (This makes me then ask, what does the Quality filter mean?)

Interesting, I wouldn’t have thought of that workflow. I like using Compare, but the Compare button doesn’t show up until there’s at least 1 ID already.

Yes, there’s a hidden verifiable on the taxon photo browser that can’t be removed, so cultivated won’t show even if you change the quality grade to any. I made a bug report for that previously, but it’s unclear if it’s intentionally coded that way.

When you set a default place in your account settings, it will initially populate that same place in the taxon photo browser. From that point you can change the photo browser location and it will be sticky and independent from the place in your account settings.

2 Likes

The Compare button tends to show far fewer photos (usually only just a handful) for a given suggested ID. By bringing up the taxon photos I can get a lot more photos, which I prefer to do just in case some of the photos might not show details I want (e.g. the Compare photos all show the flower when I want to compare leaf shape).

Also, the hidden Verifiable filter on the taxon photo browser would explain the issue I ran across. Thank you for clarifying that. (I guess I can mark your post the solution?)

(Though it doesn’t explain the geographic filter bug that @pisum found…)

1 Like

I think I did see it on the Identify page, if the filter is set to include casual/cultivated.