Community taxon issues with ant observations

Platform (Android, iOS, Website): website

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:
as one example but I’ve found and fixed many others, such as which despite all the IDs was showing the community taxon as "Camponotus novaeboracensis* with all 7 disagreeing IDs marked maverick. is an example of the community taxon appearing, but being wrong.

Screenshots of what you are seeing:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Various observations not showing any community taxon, or showing an incorrect one, despite a) there being plenty of identifications, and b) having previously shown a community taxon and in many cases the observation previously being RG. Adding another agreeing ID, or even deleting one and re-adding it, seems to force the community taxon to be “re-computed” and it appears valid.

All the affected observations I’ve noticed are of ants, but that could be a coincidence.

Apologies, I may have caused this. I’ve been ‘toggling’ some of the ants caught in the limbo of this bug:

[Edit] Once both/all the taxa in the identifications have been re-indexed out of Vespoidea the community taxon should be be back?

Interesting, I saw that thread while creating this one and wondered if they could be related. What do you mean by toggling?

Briefly making the taxon Inactive then Active again, toggling it off and on.

I’ve tried to find observations where the community taxon was not as expected, have only came across one so far. In that case ticking then unticking the ‘No’ checkbox for ‘Based on the evidence…be confirmed or improved?’ in the Data Quality Assessment for the observation fixed it.

1 Like

Oh I see. I tried the DQA approach on one and it didn’t seem to work, but if this is all gonna go away after some reindexing then I’m content to wait.

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website on Windows 10

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Edge, Chrome, any

URLs (aka web addresses) of any relevant observations or pages: Thistledown Velvet Ant (Dasymutilla gloriosa) from Manuel Benavides Municipality, Chihuahua, Mexico on May 20, 2013 at 09:23 AM by Andy Goerdel - Texas Master Naturalist, Good Water Chapter · iNaturalist

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): All 3 Ids are at the species level for the same species so I’d expect the observation to be Research Grade.

Step 1: Go to Observation page

Step 2: Review Ids made, note that all Ids are for the same species

Really weird. I even tried messing with the DQA to see if it would default to RG if changed from Needs ID, but nope. It stayed at Needs ID. It says it qualifies to be featured on GBIF, though, which I think requires RG. Weird stuff.


That is strange. It doesn’t show as having a CID, so it’s something with the added IDs (after initial from OP) not being counted.

I added and then withdrew an agreeing ID and that immediately caused the other IDs to be counted - it is now RG.

1 Like

Thanks @robot & @cthawley !

(merged a related report here)

1 Like

I’ve also noticed this issue. It seems to only apply to a few species, making all observations of that species lose research grade. Adding a new ID will fix it, but it’s quite tedious to go through all of them. Yesterday I went through the majority of Formica ulkei obs to fix them. Now I’ve noticed the same issue for Myrmecina graminicola and Carebara diversa, I imagine there are probably more. I’ll leave it for now, hopefully a more practical solution can be found?

Can you provide URLs for some of those so we can test on our server that was backed up last week (i.e. before you fixed them)?

Huh, here’s what it looks like on our test server, which was backed up this past Saturday. I wonder what changed between then and today?

Here are some that I fixed yesterday:

Here are some that haven’t been fixed yet:

OK, thanks. These appear as RG on our test server, so it seems like something’s changed since then. Please don’t fix the three you listed here so we can take a closer look.

1 Like

please look at
and look at
these 2 species have more pages like this (around 800)
thank you

This was caused by a curator attempting to fix some issues caused by previous taxon changes by inactivating and re-activing taxa. They’ve messaged us and apologized, although I understand they were trying to be helpful. This was compounded by a bug that apparently didn’t update IDs.

We’re going to run a script to resassess the IDs, but it will take some time so please hold tight. And we’ll look into a fix to prevent that bug from popping up again.


These should all be fixed now. Let us know if you find other examples that aren’t fixed.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.