Countries become rectangular when using the Location bar in Explore


When I type a country name in the top-left search box on the main iNaturalist website and select “View Observations”, the place it selects very neatly surrounds the borders of the actual country. However, if I am exploring and I type the country name in the Location box just above the map and select it there, I get a very crude rectangular shape roughly surrounding the country (cutting off some convex parts and including some neighboring countries next to concave parts of the country in question). If I do the same for a smaller place like a municipality, at least insofar as I have tried this, it always seems to still select the borders of the place accurately, same as if I had typed it in in the main search bar.

Why does this happen? Is this a case of saving server resources for larger requests? But then why would it still work fine in the main search bar? Or is it an actual bug, perhaps? I was not confident of that, so I did not ask this in the bug reports subforum, but it does seem like undesirable website behavior, to me. If I select “The Netherlands” as a location, I would rather it actually select that country, not a square that includes some of Belgium but leaves out the far south bit of the province of Limburg.

If this is not a bug, perhaps this post can be considered a feature request to make the Location filter text bar function the same as the main search bar when searching for a location.



It is intentional and I doubt it will be changed, filter and location parts are using different system.

I’m not seeing this rectangular “The Netherlands” location. Could you post screenshots and a link to this place? “View Observations” and Explore go to the same place. I’m only seeing this “(The) Netherlands”.
Here’s all the places with “Netherlands” in the name:✓&q=the+netherlands&commit=Search

Okay, but then why does it not happen for municipalities, like say Loon op Zand in the Netherlands? It shows the same shape (non-rectangular) in both cases.

Sure, here you go:

This is after I type in “Netherlands” in the “Location” box just above the map when exploring (so not in the top-left search bar) and then select it in the pop-down list. Here’s a link as well.

Welcome to the Forum!

1 Like

Thanks very much :blush:

Rather than using the search on the top right, click on Filters, then the more filters link at the bottom left and use the place search there. You will get much better results.

It’s not a bug. The site has mapping data in 2 places, from Google Maps which is what that top right bar uses and internally stored which is what the method above uses.

The site can’t store the massive number of places you can search for in Google maps, the tradeoff is it has no control over the maps there.


Location always shows rectangular map, filters show actual location, could you provide screenshots of normal map while using location? It shouldn’t be there.

Hm that’s not what I’m seeing. That link takes me to the coordinates of a rectangle (as expected), but that’s not what I get when I type in the country name.

1 Like

Now we need someone to go and clear those duplicates! :D


I’m a bit confused; I have a search bar on the top left, not the top right. Is that the one you mean? Using the more filters place search gets me the same result as if I search in the top left search bar and click “View observations” in the drop-down menu (which is the result I like; proper borders around the country). If I type directly into the Location bar just left of the Filters button and select it from the menu that pops down from there, that’s when it becomes the square.

At any rate, I’m happy to do it in the way that produces the better results, I was only wondering why there were different results from different methods. To me, it looks like the method in the search bar (or in “More filters” as you describe) gives a much nicer result, at least for the places that I’ve tried, which makes me wonder why the other method would be there at all. But perhaps that works for some places that are not (yet, or at all) stored internally. (In which case I still don’t like that it apparently also gets used for places that are, but oh well.)

Okay, here it is for Loon op Zand, the municipality where I live in the Netherlands, after I type its name in the Location bar and then select it in the drop-down menu. If I use the same method for the whole country, it becomes the rectangle, but as you can see, for this case it becomes its own shape (same as when I search for it in the search bar on the top left).

How odd. Yes, that’s how I would like it to work as well, and it is what I get if I search in the top left, or with the method described by cmcheatle just above. But not if I type directly in the Location bar.

Haha, yes, I already posted comments in there, but I don’t know what else to do to actually resolve it. It’s up to the observer, I think? Or perhaps a curator could do it.

Because Google Maps has millions of searchable locations, which is not something iNat’s infrastructure can handle storing internally.

1 Like

Right, that’s what I figured (and speculated just after that quote). That makes sense, thank you. That said, it would be nice if it somehow recognized if a place is stored internally, and in that case uses the stored place rather than the place from Google Maps. As it looked like it was doing for thomaseverest up above, oddly.

But failing that, I’m happy to just use the other method from now on. Searching in the top-left search bar had the same effect, but that requires starting a new search, so the “more filters” option is nicer, so thank you for that, as well.

Are you running your computer in a language other than English? (Not iNat, your operating system)

No, I am running it in English, well, my OS anyway (Windows 10). My native language is Dutch, but using English makes it easier to troubleshoot problems when searching online.

This seems like a bug to me, but since I can’t replicate it I wonder if it’s tied to a settings difference somewhere, such as language (as mentioned above), place prioritization, browser, etc.

1 Like

You need to flag it, I mark them as no evidence of organism. There are also duplicated nuthatches, in different poses, but I can’t open them as link is opening weirdly on my phone.
Always use filters if you want right place borders.

1 Like

Hm, okay. Well, I’ll just share some of my settings just in case it gives someone any ideas or if it’s used later for bugfixing, if indeed it is a bug.

OS: Windows 10 Pro 64-bit
OS Language: English
iNat language: Normally Dutch, but switched to English for screenshots, had the same behavior in both cases.
Browser: Google Chrome, version 89.0.4389.128 (Official Build) (64-bit)
Place prioritization: Uh… not sure what this is, sorry.

If there’s anything else anybody would like to know, please feel free to just ask me, and I’ll let you know.

I see, so you just mark all but one of the duplicate observations as such, then? EDIT: I actually cannot find a flag option other than “Flag as inappropriate”, but that seems to be intended for spam and the like.

Oh right, those were actually what I was talking about, but I see the finches now, too. The nuthatch is here, with links to the others in my comment there.

1 Like

Cities also seem to become rectangular or squared, and entire sections of the cities are cut off and observations from those areas that were cut off do not show up when the city is searched.

For example, when I search Keizer, OR, USA in the search bar, Keizer Rapids is not included as part of the city at all. It’s too bad that we cannot type in the desired coordinates into the search bar, then any observations that were uploaded inside of those coordinates show up.

1 Like