Search engine with problems with word brazil

Platform (Android, iOS, Website): Website accessing with firefox 78.15.0esr, in a Debian 11.

Step 1: when i put brazil in the location and press enter it goes to this page:
https://www.inaturalist.org/observations?place_id=22912&subview=map

Step 2: which is actually from the city of brasilanda. So I can’t do search in Brasil.

thanks,

I can’t replicate. Which search bar do you mean? In Explore, “Brazil” brings me here:
https://www.inaturalist.org/observations?place_id=6878&subview=map
and “Brasil” brings me here:
https://www.inaturalist.org/observations?nelat=-15.57835317069656&nelng=-47.78495095806188&place_id=any&subview=map&swlat=-15.86517106767984&swlng=-48.0897646724088

In the Explore filters you can see all the iNat places:
Screen Shot 2021-11-27 at 10.17.26 AM

2 Likes

I used to get this error from time to time too, usually when I typed part of the word “Brasil” and it would give me this Brasilândia pick only in the dropdown list of the type area. Tried to replicate it now, but no luck.

1 Like

Are you running iNat in Portuguese? If so, this is part of a known problem that has to do with the handoff of the search results from Google to iNat. It should work if you use Filters->More Filters->Place, like in the screenshot thomaseverest posted.

2 Likes

This happened to me a lot of time, and I believed it was only me!! it happens with the word Brasil and Brazil…

1 Like

Yes, I am using INat in portuguese.

If I tip in the first page, as the screenshot below, even if I complete the word Brasil or Brazil, it sends me to “Brasilândia do Norte”.

And now I just test, fill the place in the explore filters and it worked fine. I sill use like this for now on…

thanks,

Forgot to attach

I changed my language setting to “Portugues (Brasil)”, then searched in the upper box for “Brasil” and got https://www.inaturalist.org/observations?place_id=6878&subview=map. Maybe I’m using the wrong Portuguese setting?

It needs to be set in your browser.

1 Like

Okay, that’s the problem then. How do I do that?

In Chrome, for example, you open the browser settings, then you can search for the language setting, then you would have to install Portuguese and choose that. Then reboot the browser.

1 Like

Found it. I see the problem now. When I search for “brasil” the first option is “Brasil” but it actually goes to “Brasilia de Minas”. The search box in the Filters works though, so just use that instead.

2 Likes

Yes! Exactly what is happening here!

I will use this other way. Thanks for everybody. <3

1 Like

Hello,

A little bug to report (I’m from Brazil).
When I write “Brasil” in the part “Explore”, it is the Brasília map that appears (see the sreenshot).

Many thanks

Danilo Rosa

When I type Brasil and hit enter, it focuses on Brasilia (the capital of Brasil). But when I type Brasil and then select Brasil from the drop-down list, it focuses on the entire country of Brasil. I’ll leave it to someone else to determine if this is an iNat bug or a quirk of this being a Google Map. But when I’m on Google Maps, type Basil and hit enter, it focuses on the country, not Brasilia.

1 Like

it happens with Brasil and Brazil, and used to think I was the only one with this trouble :O

1 Like

@danilor welcome to the forum!
I moved your report to this existing topic because the problem and temporary solution are the same as reported here. The reason this happens is because you are running iNaturalist in Portuguese and the name of the country is spelled Brasil in Portuguese, but Brazil within iNaturalist.

When using the Location search on the Explore page, iNaturalist tries to look for a place called Brasil, but it doesn’t find the country, it finds Brasília, which it thinks is a closer match. To avoid this problem, please use Filters->More Filters->Place.

Screen Shot 2021-11-27 at 10.17.26 AM

1 Like

Thanks, I managed to solve the problem!

1 Like