Create/edit/cancel taxon scheme leads to 404 Not Found mole page

Platform: Website

Browser: Firefox, Chrome (not a browser issue)

URLs (aka web addresses) of any relevant observations or pages:
https://www.inaturalist.org/taxon_scheme_taxa/468762/edit
https://www.inaturalist.org/taxa/41964-Panthera-leo/taxon_scheme_taxa/new

Description of problem:

Step 1: Create a new or edit an existing scheme for any taxon
Taxon page > Taxonomy section > Taxon Schemes > Edit or Add

Step 2: Add or modify details as required

Step 3: Save or Cancel, either will redirect to a malformed link resulting in the 404 Not Found mole page

Just checking that this is not a new issue, correct? I suspect this has either been the case always or at least since the taxon page major overhaul at least 3 or 4 years ago?

I’ve only updated scheme ids in the last few days, it’s been broken for every one. Unsure what the state was prior.

Pretty sure this has always been like this, or at least since the taxon page revamp several years ago.

Most of the uses of Taxon Schemes have been replaced by Taxon Frameworks. These are tracking how iNat taxa map to external sets of taxa. Taxon Schemes never really worked well for this because unlike Taxon Frameworks they don’t truly accomodate non-1-to-1 mappings (they try to do this by mapping through taxon changes but this never worked well). Unlike taxon frameworks that can only map to one reference, taxon schemes in theory could map to many references but because they were always sort of broken for the mapping use-case they don’t really succeed at doing this.

They are still used for storing the GBIF taxonid to show the GBIF points on the map

If thats their only remaining use case, they could be stripped back/simplified substantially.

Is anyone aware of any other remaining use cases for them?

Updating GBIF ids for the map points is how I came across the bug.

I have definitely edited taxon schemes in the past and I don’t recall ever getting a 404. But the last time was like a year ago, so maybe I’m just not remembering.

I don’t use them for anything other than GBIF points and would be happy to see them simplified.

Seconding Jane’s comment in all points: the error is something new when updating the GBIF link, that’s the only use I have for it at the moment, and would be nice to have it simplified.

1 Like

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Step 1: Find a taxon where the GBIF schema data is not yet entered. Any taxon whose ID is greater than 1250000 will likely do

Step 2: Search for the taxon on GBIF and get the required ID

Step 3: Add a new GBIF schema to enter the data

Result after saving is a search error. The schema data does appear to be saved. The page tries to direct you to is (Specific to the taxon of course)
https://www.inaturalist.org/taxon_schemes.1226368-Ypthima-abnormis

when the proper URL it should try to get to is https://www.inaturalist.org/taxa/12263678/schemes

(moved to existing report)

Pretty sure this is the only thing schemas now do. I would assume for GBIF at least, there is no reason not to switch it to a Wikidata lookup as is done for other things, such as Wikipedia language specific pages. It would be much easier to just leverage the data there.