Updating IDs after taxon change doesn't always work

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : Firefox

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I’ve opted out of having my IDs automatically changed with taxon swaps as a bad taxon lump could destroy a huge number of hours of identification work. Because of this, I have to manually change my taxon identifications using the “commit taxon change” tool. I’ve noticed many times that it prompts me to do this but when I go there, it doesn’t show me anything to update. I just found one example that shows at least part of it is not working. My identifications to Urtica dioica ssp. holosericea do not show up on the “commit taxon change” page for that taxon. It says 0 for everything under “your content”. Note that this is an identification for myself and not for others if that matters.

Here’s another one:https://www.inaturalist.org/observations/126290743
Also an identification on my own observation, so maybe that is a connection. This one is at species rank rather than a lower rank, so rank doesn’t seem to be connected to the problem.

1 Like

Update: This recent taxon change worked perfectly fine to update my ID for my own observation. I have no idea what makes this one different from the ones that didn’t work except that it is a bird and not a plant, which probably has nothing to do with the problem.

Still doesn’t work. I can’t “change my matching observations to this taxon” on this one either. Does that look at the community ID or something, which makes it not match? There is an “identifications for others” option but no “identifications for myself” option. Perhaps that is the issue?