CSV import does not work

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I have created a CSV-file out of Excel (“save as” → CSV UTF-8) following the formatting in https://www.inaturalist.org/observations/import#csv_import

Step 2: “Taxonname” is filled with scientific taxa (binary nomenclature) only; Date is filled; Coordinates is filled; all other fields I left empty, so no quotation-mark-issue with text should occur

Step 3: uploaded the CSV-file

Afterwards I received an eMail from iNat regarding the first 100 table rows e.g.:

  • Single taxon not found: Leptoptilos crumenifer;2013-03-27;;;-.02849;30.05951;;

    • Zeile(n): 2
  • Single taxon not found: Circaetus cinereus;2013-03-27;;;-.02849;30.05951;;

    • Zeile(n): 3
  • Single taxon not found: Lophaetus occipitalis;2013-03-27;;;-.02849;30.05951;;

    • Zeile(n): 4
  • Single taxon not found: Clanga pomarina;2013-03-27;;;-.02849;30.05951;;

    • Zeile(n): 5
  • Single taxon not found: Numida meleagris;2013-03-25;;;-.25654;30.02576;;

    • Zeile(n): 35
  • Single taxon not found: Guttera pucherani;2013-03-25;;;-.25654;30.02576;;

    • Zeile(n): 36
  • Single taxon not found: Pternistis afer;2013-03-25;;;-.25654;30.02576;;

    • Zeile(n): 37
  • Single taxon not found: Ardea melanocephala;2013-03-25;;;-.25654;30.02576;;

    • Zeile(n): 38

and so on

Any suggestions how to solve the issue?

Thanks much, Kay

You have to follow the instructions as in point 1.
Step 1: I have created a CSV-file out of Excel (“save as” → CSV UTF-8) following the formatting in.

I am surprised the Taxon does not need quotation marks but the example shows not.
Any idea how to generate quotation marks in Excel?
The example shows an ;-delimited text file. I do not know why iNaturalist does not support this cause it seems the best way forward in stead of ,…. You have to replace the ; with a ,

Zeile->Row
A bit strange but not all lines generate errors, only 2,3,4,5,35,36,37?

1 Like

Thanks much!
Do you think the taxon does need quotation marks?
I do not have any idea how to generate quotation marks in Excel, unfortunately.
And do you suggest rather to ,-delimitate the CSV file?

BTW: All the lines generated errors - I just put in examples.

Thanks for your help

  1. the example does not have quotation marks around the taxon and mine CSV also not ( will send a PB).
  2. Yes, I expect ,-delimitate. It is sad, I should also prefer a ;-delimiter

You should use commas as field delimiters and not semi-colons.
CSV stands for comma-separated values.
If the field text already contains commas then quotes are automatically inserted (by Excel) around the field text.
Also pay attention to the format of field header labels. For example, it is Taxon Name (with a space) and not Taxonname.

Don’t think so but maybe I have to add the comma’s. Comma’s are used to separate in longitude and latitude. That makes comma’s bad separators… I expect header names are not importand, they will be skipped.

This table in Excel:

Produces this (viewed as text) when saved as a CSV:

Marking which commas separate values vs. which commas are part of a cell’s contents is the purpose of the quotation marks. Without that convention you’re right, there would be problems resulting from the use of commas within a cell.

(Excel 16.56 for Mac, for what it’s worth; I believe the behavior is the same across all flavors of Excel, but can’t verify.)

I just tried an example with Excel for Microsoft Office 365 and it does automatically insert quotes around field text containing commas when you export a file as CSV. You should not have to manually add quotes.
You could try other tools to import and export the data as CSV.
Notepad++ has good file exchange filters, or Google Sheets.

1 Like

Thanks for all your answers.

I wonder why iNat messages “Single taxon not found”. Even very common species like Anser anser or Abies alba were not found. This seems to be an issue regardless of comma- or semicolon-delimiters. Don’t you think so?

The reason it failed to find Numida meleagris is because it wasn’t searching for Numida meleagris, it was searching for Numida meleagris;2013-03-25;;;-.25654;30.02576;;. If the delimiters are not what it was expecting (semicolons instead of commas), it won’t know how much of the text is the right amount to use for searching. If you switch to only commas as delimiters, it should work – please report back if it doesn’t.

2 Likes

Thanks everybody! Indeed the solutions was to separate columns with komma not semicolon. However, Excel unfortunately did not what could be expected when exporting the file as CSV (in none of all the CSV-versions provided with the export settings) - it always separates with semikolons.

So I imported the Excel-file into Filemaker (database) and exported from there as CSV. FileMaker did what I expected and separates with kommas.

Moreover Filemaker allows to fix some bugs within the data very quick and easy and a few trials later the errors were reduced to zero. I skipped very few species in my data that iNat wasn’t able to find when importing (such as Abies alba).

I was positively surprised that iNat was able to import >13.000 recordings (CSV was that large).

So again the key was the komma-separation instead of semikolon!

Thanks again for all your help!

Best regards, TT

1 Like

Export from Access supports the export format for iNaturalist.
Guess this topic says 10 times you have to use comma’s… …

i believe this is based on what you use as your default decimal separator. if you use the comma as the default decimal separator, then your export CSV delimiter will default to semicolon. if your decimal separator is a period (and even if your thousands separator is a comma), your export CSV delimiter will be a comma.

1 Like