Error when submitting id or comment on tab left often from previous session

Not sure if this really a bug or just something stupid I keep on doing. Frequently I’ll leave iNat observation pages open in my browser when I want to remember to look at them again to id or comment on another day.

The tabs get retained when I close and then reopen my browser later and appear normal. So I go to select an id and sometimes type up a long explanation with links, etc. in the comments. I hit submit and get an error message and everything I typed is just gone.

I’m not even able to hit the back button to go back and retrieve the text I typed out like you sometimes can with forms that fail to submit. If I reload an old retained iNat browser tab before typing out something and then submitting it will work fine… but I often forget to do that! Any way to not wipe out the text in the box when the form fails to submit? Or why does the form fail to submit on retained tabs for me?


Is there a way to change how the form submit works on the observation pages? It’s very frustrating. I just got burned by this again. I typed up a long comment on an observation with links and all, then hit submit and got the dreaded “failed to save record” and it wiped out everything I’d typed!

Most sites if a form fails to submit, it doesn’t completely erase the form contents in the process. On many other sites, even when I submit a form and it loads another page and then throws an error, I can still use the browser back button to go back and my form contents are retained.


That’s never happened to me. How long is the page open before you hit Submit?

I thought it was primarily happening when I’d left a tab open in the browser from a previous session. But, I just tried to recreate it by leaving a tab open and then closing and reopening the browser. The comment form submitted fine without having to reload the tab. So maybe it is a matter of a session timeout that is reset based on time passed and not reset by closing and opening the browser. My login status is always retained, so it’s not that. I know other people have mentioned this problem on other threads here in the past, and said that they always tried to remember to reload the page before typing up a long comment. I don’t really mind the error message so much, it’s the deleting what I’ve typed in the text box. If it showed the error but left the text… then I could copy it, reload the page, paste, and then submit it.


Or if we warned to refresh before typing the comment?

1 Like

(moved this conversation to a new category since I realized it wasn’t related to the original bug report)

Had this happen again yesterday. This time it was in a browser tab that was opened a couple of days earlier. When the browser is opened again the old tabs appear to be reloading, but maybe it is only loading a cached version because the page hasn’t actually changed. Maybe then the token is incorrect or something which causes the error when the form is submitted? I don’t know much about it, my web-design and coding knowledge is very out of date!

I did notice that after the error message when I tried submitting a second time without manually reloading the page, I still got the error message. So submitting the form is not reloading the page, which to me means it should be easier to not wipe out the form contents in the process. Re-selecting an annotation or two is easy and no big deal, but having to retype a long comment is a real pain.

I believe the token expires after a fixed amount of time, I’ll have to ask our developers for details next week, although because of the holidays here in the US I can’t promise we’ll be able to get back to you soon.

1 Like

It’s certainly not an urgent issue by any means. I was just hoping there was a simple solution for it either on iNat’s end or with a browser setting. Something other than the simple task of remembering to reload the page before I type up a comment. I seem to be incapable of doing that!

1 Like

I write long comments in Word then copypasta.

I usually don’t experience this issue because I generally write my comments and send them at the same time, but I just had it… I partially wrote a comment and then closed my laptop for a couple days while travelling. I opened it up again tonight and saw the unfinished comment, and then finished it and sent it. It failed, so I wrote it again and sent it and it failed again. Finally I realized I needed to manually refresh the page, then I rewrote it all a third time and it worked.

Thanks @bouteloua for linking the newer thread on this to the older one I’d made. These newer posts were originally just comments on a thread someone else starting recently about getting the same error message when doing annotations. My post there about the same thing happening with comments and ids then got split off as another new topic.I imagine it’s all the same issue though since it’s probably all part of the same form submittal process.

My problem isn’t so much half-finished comments. I tend to regularly leave pages open when I want to remember to comment later or do some more research before I make an id. Then I end up with a bunch of new and old tabs open, and forget to refresh the old ones before attempting to submit the form.

Another idea is how some sites automatically detect when you’ve been away too long and log you out once the tab gets the focus… like banking sites. I don’t want to be logged out of iNat for inactivity, but some type of heads up message that the form submittal won’t work without a refresh when the tab gets the focus would be nice. That is, if retaining the form contents after submittal isn’t possible for some reason.

I was going to start a new thread but then found this old bug report.

I can confirm the symptoms reported by molanic. As mentioned, losing a typed comment is a major issue. I’ve been burned by this bug many times.

If the page expires, can the user be prevented from typing a comment in the first place?