Fail whale on search for a name

I knocked out a bunch of ungrafted cowrie subspecies thanks to this new page and I thought I’d try a normal iNat search to see if there were any others. I typed in Cypraea and selected View More. I clicked the tenth page and got the whale shark. There is no eleventh page so I thought the issue might have been because it was the last page but I can’t replicate it with any other searches (although I didn’t try and find any with exactly 10 pages). I know there’s 2 other taxa that I left ungrafted for the time being and I can search the above link to find them, so this doesn’t stop me from getting the results I wanted but it still seemed like a bug. Neither of the ungrafted taxa (this and this) are on any of the other 9 pages but I don’t have any trouble navigating to them any other way.

Page 9:
Page 11:
Page 10:

Clicking next from page 9 gives the same thing (it goes to the same URL so that makes sense, but sometimes those things are weird).

Might be related to:

Using Chrome on a Mac.

1 Like

probably this:
a variant:

you can find similar taxa, i think, by excluding the rank parameter from the url when you use jwidness’s tool ( and looking for taxa with no id.

Aha that would make sense. It doesn’t really seem to exist. It shows up in the search but comes up as null if selected. Definitely the same issue as those other bugs I linked to. I can’t make it the input of a swap. I can’t add an observation with that as the ID.

Should this get merged onto one of those other topics?

i think so. it will probably help to see everything all in one place.

i think this has been fixed, or at least worked around. i can see there are still taxa records with no id (ex. Cypraea hammondae dampierensis): but searching for such records will now return “no results found” instead of a fail whale. this might be the code that killed the whale (shark):

Yes looks like the initial problem I had was fixed, but the taxon is still uneditable.

i don’t know what the taxon editing screens look like, but can you just (re)create that taxon?

Well yeah I don’t need it for anything and it’s a taxon inquirendum with no observations so it could probably just be “deleted”. But I can’t flag it for deletion or swap it into the correct genus. It’s more just my desire to tie off loose ends. :)

i guess what i meant is maybe it would be possible to create it (so that it would get an id), and then “delete” it immediately after, thereby making it go away. again, i’ve never seen what all those taxon editing options look like. so i’m not sure if what i’m suggesting even makes sense…

I tried creating one and then there were just two. It’s weird though that the null one isn’t in italics. I’m not sure what rank it is and I don’t know what would happen if you tried to create one with the same exact rank too.