How do I remove author from base taxon name?

Now and again taxon names are created that include the describing author, e.g. https://www.inaturalist.org/taxa/1281196-Commiphora-pteleifolia-engl

I tried a couple of ways to correct this by editing the taxon associated names but my attempts failed with different error messages and I can’t edit the name through the edit taxon page, probably because I didn’t create the taxon. The user who did create the name is not a curator so they may have trouble correcting it too.

Is there a procedure to correct these mistakes without resorting to a taxon swap?

There’s a bug in the name importer causing this. All(?) names imported from EOL in the last month or so with the author listed there have been import incorrectly.

Only staff or the creator of the taxon can edit the name. The majority of the other malformed names have been fixed with taxon swaps.

3 Likes

Just adding the link to the Bug Report for cross-reference.

2 Likes

Scientific names of taxa can’t be edited unless you manually created it. Since these come from the auto importer; the only option is to create the proper name and swap the malformed one I to it via a taxon swap.

When it doesn’t have any IDs yet, you can just inactivate it (and create the properly named one if it doesn’t exist yet).

2 Likes

Similar to what others said, only curators can change taxa/scientific names, and only they can “prioritize” which common names are displayed (non-curators can add second common names, but they won’t be displayed). All curators should know not to add authority name or date, so any examples like that are probably due to automatic processes/errors.

2 Likes