Image viewer not displaying all images for Dicaelus politus

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Website):

App version number, if a mobile app issue (unkown if replicates on mobile app):

Browser, if a website issue (Chrome, but works on Firefox!) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (not incl.):

Description of problem :

Step 1: The info page for Dicaelus politus ( shows nine observations for Dicaelus politus, six of which are at RG. A sample image is shown on the left. So far, so good.

Step 2: Expecting to see the remaining images, I click on “View More ->” and open the Image viewer (, but see no RG images at all. Ensuring all filters are set to “Any”, I now get (only) two images from one observation. Where are all the rest?

Step 3: The images are also missing from the next higher taxon rank, Paradicaelus (, but only for that one species. The other species in that subgenus seem to all be displayed correctly.

Step 4: I have not encountered this problem before. I then tried a different browser (Firefox) and all the images displayed just fine! So, the problem is limited to Chrome (as far as I can see).

1 Like

seems like this is a return of a problem described before, with a workaround described here: Taxon page photo browser not displaying photos properly - Bug Reports - iNaturalist Community Forum

Yes, I started that thread too. The problem is different in that all the filters are visible this time, and the work-around solution (toggling through the drop-down options) does not re-set the problem.


worked for me. i changed the Dead/Alive to Yes, and then to Any, and now i see everything lots of photos for D. politus.

Was it not displaying any images for you when you originally checked with all filters set to “Any” and “None”? I will try rebooting computer and clearing cache.

there were 2 photos originally, as you noted in your original post. setting it to alive and then any allowed me to see a lot more photos. does it not work for you?

I tried toggling all the options without success. One of the filters must have been stuck though.
I have re-booted and cleared cache and now it works.

Thanks for checking at your end,