Taxon page photo browser not displaying photos properly

Problem continued until I toggled through the “Grouping =” filter. Then when I returned to “Grouping = None”, the full functionality was restored and all images are visible in the photo gallery. I note that I have never used this particular filter before.

Just encountered the same issue

and then fixed it using this solution as well

I’m having the same issue with viewing images, but toggling the “grouping” filter does not fix the problem.

I still can’t replicate after trying in multiple browsers using multiple taxa and filters. Can you please share screenshots of the browser’s console for pages where you can’t see photos? In Chrome, go to View > Developer > Javascript Console.

We’ll take a look into it this week.

After doing extensive testing, I believe all of the reported issues could be explained by having an annotation filter that might not show in your photo browser options (except in some cases under Grouping - see my other reply) and contains a value that is not relevant to the current taxon. The end result is that nothing matches.

For the impatient, here’s a workaround:

Skip all my lengthy explanation and just find a taxon that has an annotation filter that is set (i.e. doesn’t have “Any” value). If you’re having trouble in one particular taxonomic tree, go to a different one (like if it is Flowering plants that don’t show up, try Animals, and vice versa). The key is to find one that has a menu from which you can choose “Any” again to clear the stuck filter. Once you do that, you should be able to see all photos in your other taxa again.

What’s going on and how to reproduce it:

The last time I was in photo browser I clearly recall I had filtered on life stage = adult. Today, I tried the photo browser for a taxon for which life stage is entirely not applicable (Usnea longissima). It shows no photos, and no option to unset life stage:

Behind the scenes, it is trying to apply the life stage filter via this API call:

Note the presence of &term_id=1&term_value_id=2 filter in the query. That should not be there.

  • Toggling grouping was ineffective.
  • Navigating to Arthropoda and opening the photo browser gave me access to life stage once more.
  • From here, I was able to clear the life stage filter.
  • Then, I navigated back to the problematic display:
  • The photo browser shows photos again:

And of course, the observations API call URL no longer includes the annotation filter that was screwing up the search:


Reasoning that my situation (arthropoda -> fungi) was somehow different than yours (maybe plantae? -> animalia), and that made the difference re. Grouping fix, I tried:

  • visit Flowering Plants
  • select plant phenology Flowering filter
  • visit Anura
  • browse photos (no matches, as I expected from my other test)
  • toggle Grouping
    • unlike with Usnea, I had some options other than None and Taxonomic; toggling between those was ineffective
    • however, it does have Life Stage Grouping, which in Animalia corresponds to Plant phenology in Plantae
    • when I toggle to this and back, it fixes the issue

But depending on which annotation filter you set initially, and which one you’re having trouble with, you may or may not have a Grouping option available to you that you can choose to workaround the issue. With Fungi you are particularly out of luck because it has neither Life Stage nor Plant Phenology, so there is zero overlap with “stuck” filters on either of those.


And with this description, the problem is able to be replicated.

  1. I just opened the photo viewer in Rusty Willow Sawfly and see all the images.

  2. I then navigated to the Monarch butterfly page and selected “Life Stage = Larva”

  3. Now, when I return to the Rusty Willow Sawfly image viewer it shows no images.

Thanks Ben!


Here’s a github issue for this:

Thanks for all the sleuthing, @benarmstrong!

1 Like

Thanks everyone - I just logged in specifically for this bug that has been peeving me for a while now and I see there is at least a workaround for now.

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : any (verified with both Firefox & Chrome)

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Viewing the URL above while logged in as myself, I get just the text “no observations yet” with no photos. The same thing while I am not logged in shows many photos. It must be some sort of filtering, but there’s nothing specified on the URL (and “Filter by Place” isn’t on). What else is sticky?

This has been happening for some time, and I just kept forgetting to report it.

I have been getting this for quite some time, too. Using Firefox on a PC. I haven’t tried to see if it is different if not logged in.

PS- In reading further down the forum I discovered other posts about this issue, and the work-around of the “Grouping” setting.

Platform Website

Browser Chrome

URLs (aka web addresses) of any relevant observations or pages:

but the same results seem to happen on any species I try.

Description of problem When on a taxon page and you I click View more photos, no photos are shown even though there are plenty of observations of this taxon (See screenshot).

Interestingly enough when i open an incognito window and go to the exact same URL it works and displays photos as expected. Then, after I log in in that same incognito tab, the photos are then gone as soon as I log in.


The same has happened to me quite a few times lately; For some reason it shows “No observations yet”, no matter what species you try to see “more observations” of. However, after a while it works again - seems to be one of those intermittent things?

Seems mostly fine now but just got it on

Web Version 87.0.4280.88 (Official Build) (64-bit)

Change grouping workaround works as expected.

Platform (Android, iOS, Website): website
Browser, if a website issue (Firefox, Chrome, etc) : Chrome
URLs (aka web addresses) of any relevant observations or pages: (= example of a species page where you can click on the ‘more’ button to get an overview with pictures of the species)

When I click the ‘More’ button on any species page to see more pictures of that species, then (see next picture)…

… I get an empty overview showing ‘No observations so far’

Am I the only one with this problem? :)

Thanks in advance.

1 Like

i’ve been having this issue as well!
edit: it’s working now, weirdly enough. it wasn’t the other day.

I have this same problem with several taxa. Sometimes I find a hidden filter for term_id and if I remove everything from the URL from ? to the end, I can see the photos. Sometimes if I apply and remove filters, it then works but not always. It seems that when it fails for me, I eventually end up with this troublesome string for several taxa: “term_id=12&term_value_id=14”. Maybe that’s a clue or maybe just me.

I’m using Chrome on MacOS 10.15.7, Catalina.

I tried a test of several taxa using Safari and didn’t have any trouble, but I haven’t been using that browser much recently.


Had the same issue since three days ago in all taxa I browsed. i followed your guidance and now I do these three steps for every taxon:

  1. let’s say the original url path is:
    Here no photos are displayed.
  2. I click on the grid layout option that is not active, now the url path changes to:
    Still no photos are displayed.
  3. In the url path I delete this part: “&term_id=1”, and press the Enter key
    Now the photos are visible

removed “term_id” filter and I can see the photos again,

Hope this gets fixed soon

1 Like

OK, so the original bug here has been fixed - if you have set a filter which does not apply to the current taxon (eg Sex: Male for one taxon, and then load Kingdom Fungi, which has no Sex filter), you won’t be prevented from seeing photos. At least I haven’t found any cases where you see “No observations yet” even though there are observations that should load. If you do, please provide specific details.

There are a few kinks needed to be worked on, such as filters that should be “sticky” becoming unstuck, we’re looking into those.