iPhone app instantly crashes when attempting to open specific notification

Platform (Android, iOS, Website): iOS app

App version number, if a mobile app issue (shown under Settings or About): version 3.26, build 670, on iOS 15.6.1

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I don’t know if this first part is related to the problem, but just in case it’s relevant.

Opened the iOS app and tapped the activity tab; saw that I had two notifications. Before I could even tap either of them, a pop up appeared covering the whole screen. The header said Privacy, and there were two items, both with a slider I could push to indicate agreement or disagreement. First item was did I agree to share some of my personal info with iNat, second was did I consent for data to be sent to the USA. I didn’t get a chance to do anything on this screen before it disappeared before I could click anything.

I opened up the first notification (the matthew_connors one in the image), no problem. I go back and try to open the top notification, and the app instantly crashed/closed. I can do anything in the app except for open that notification; as soon as I tap it, the app instantly crashes. I tried opening 20+ other notifications, all worked perfectly.

I haven’t opened the notification yet on desktop in case I need it unopened to troubleshoot.

I decided to open it on the computer, no problem. However, tapping on that notification on the app, even though it’s now been opened, still causes the app to crash

Can you open the observation from your profile (or any other way, but not via the notification) without a problem? I’m just wondering if it might be the observation itself that cause the crashing, not the notification.

I can try, but it’ll take a lot of scrolling on the phone; it’s from quite far back

Is it possible that this is more of an issue with your phone? I’ve found that the app can be pretty susceptible (more so than a lot of other apps too, unfortunately) to crashes and lag when my phone is going slow or has too much running in the back. A lot of the time it’ll be exactly what’s happening to you too, where it’s just one specific observation not working, and the app closes immediately. Usually if I close out of everything else I have open or log out and log back on, the problems will stop.

1 Like

I logged out, logged back in, now there’s no issue. God knows why that fixed it, but worked as you said, so thanks