Journal posts have lost formatting

Yes they do. But why the colour is blue I dont know. That is one of the current effects of whatever has happened, in the other Project report ie https://inaturalist.nz/posts/37415-methodology-trial-report-for-year-two

Image links seem to be broken throughout both Journals.

@tiwane Can you help please? I have copies of both Journals as pdfs and the regular save-as-webarchive, made at time of publication, if that helps.

Is this not because of the inclusion of vanilla https://www.markdownguide.org/basic-syntax/ as a formatting tool?
A lot of my old journal posts (pre vanilla) are doing spectacular things.
And the preview does not work - it shows something quite different to the published version.

2 Likes

</a href> is not a valid close tag. replace the invalid tag with the proper close tag (</a>). see: https://forum.inaturalist.org/t/tags-for-links-no-longer-hidden-in-about-project-pages/14273.

4 Likes

This seems likely. When did this happen? I am wondering whether my funders would have been confronted with this and not mentioned it, as in the case of the OP link it looks normal enough, then just looks at first glance like a very lazy and unskilled writer not using paragraphs Nd not knowing how to use bullet points.

Next I need to know if it is going to be remedied, as otherwise I need to decide whether to delete those posts. SUCH a lot of work went into them.

If it is just a matter of removing the “ref” from the “aref” tags I might do some of that.
I had been keeping up with the news and Updates…I thought. Maybe I missed one. @tiwane had warned me …after an earlier change that broke some things in published Journal posts…that Journals would be affected by complete change in the future…but time must have slipped by without me realising it.

Thanks pisum

This is part of the move to Amazon Open Data. Images that are Creative Commons licensed are now being hosted on a different server and we finally started deleting the duplicates on our old server. See https://forum.inaturalist.org/t/representative-pictures-not-showing-on-all-species-pages/25401/7

You’ll have to change the domain for each img_src URL from https://static.inaturalist.org to http://inaturalist-open-data.s3.amazonaws.com eg https://static.inaturalist.org/photos/82822264/original.jpeg should be http://inaturalist-open-data.s3.amazonaws.com/photos/82822264/original.jpeg That should work, as long as the photo is still attached to an observation or other content.

As for the large blocks of text, that probably has to do with our switch to markdown, which happened about a year ago.

We’ve never officially supported using iNat as an image hosting service for stuff like journal posts, so if a user uploaded an image with an observation then removing them from the observation just so they could use the image in a journal post or comment (I’m not saying you did this, @kaipatiki_naturewatc, just saying this for anyone who might have a similar issue), that photo could be gone. We recommend using an actual image hosting service if you want a place to host images for things like this.

The text formatting is due to the change to markdown support, which happened over a year ago. You probably want to start playing around with the lists you have in your posts, some are not showing up as sublists because they’re not indented. Here’s a guide to lists in markdown: https://www.markdownguide.org/basic-syntax/#lists-1 For example, try indenting your list items two spaces. Here’s what that looks like on the edit page:

I should look something like this when published:

Thank you Tony.

I updated the address for an image and it worked. Then I did another and it didn’t, and it was in a table.

What change is needed for this table?

etc–deleted text
I can’t copy the text without it changing. I tried the reformatted text button

I found a table that was working and copied that.

I have tried reading the guide you linked @tiwane but I dont see anything about paragraphs or color. I cant make sense of much of that guide unfortunately. It uses terms I dont know. Googling , eg Markdown and Color, shows me code to use if I were starting fresh, but I dont see anything to explain why text has gone blue.

Nor do I see anything about the combined effects of whatever was the previous iNat journal formatting protocols and the present ones.

The Ordered List guide is very confusing to me, eg the numbering options, what text goes where, especially in the context of my existing work which used lists within lists but without Markdown…

eg 1. Xxxxx

1:1 yyyyyyyy
1:2 zzzzzzz

  1. And so on

I dont know why there are changes of colour and loss of lists and paragraphs in the Gahnia Grove report, formatted (successfully) after I learned about the formatting options using Markdown, eg for a table and for the Contents links.

I have tried copying sections of that report into new posts and seeing if it comes right in little bits, but so far have had no success.

The image links were straightforward to update.

I will keep experimenting with short test posts, but if anyone has any clues I would appreciate suggestions.

A simple example, from https://inaturalist.nz/posts/37415-methodology-trial-report-for-year-two:

Gahnia Grove Methodology Trial Hours for 2019/20

The hours of site work for the year 2019/20 have been recorded separately

or, using preformatted text button in Forum,

<a name="hours"></a><strong>Gahnia Grove Methodology Trial Hours for 2019/20</strong>  

The hours of site work for the year 2019/20 have been recorded separately

This should appear as a “title” (Gahnia Grove Methodology Trial Hours for 2019/20) in Strong type, followed by a new paragraph.

I have tried adding two spaces at end of title line, at beginning of new paragraph, and Return for empty line/s between. Nothing restores the new paragraph in the Journal, which used to appear as it does here in the Forum…(although for some reason here in the forum part of the Name line is cut off, though I have checked and rechecked this post and the text is there between the Preformatted text characters)

I dont have a lot of confidence in applying some of the Markdown Syntax Guide directions as they frequently refer to incompatibility between applications using Markdown, and I don’t know where iNat falls in this.

eg In the Syntax guide it says

Here’s a Heading

and advises that for compatibility between applications a space should always be added before the number sign, as in this example they provide.

However, my headings work as links to blocks of text withihn the same Journal post, but if I add that space before the numbert sign they no longer work as links.

I have found that by publishing sections of the report separately, correct formatting is returned.

For some reason I am often encountering a greying out and strike through of the Save button for the editing of posts.

Has there perhaps been a change in accepted length of Journal posts?

i think it’ll be really hard to help you if there’s no way to see what you’re seeing. just for example:

  • the journal post that you referenced in your original post in this forum thread seems to be gone (or is now unpublished?)
  • the Gahnia Grove Methodology Trial Hours journal post seems to be unpublished (so that no one can see it but you).

if you’re not going to make the journal posts available so that others can see, then at least posting some screenshots would help us be able to help you.

otherwise, all your thoughts in these posts seem to be jumbled together into one indecipherable mass. what started as a thread about a journal post that did not properly separate paragraphs seems to have morphed into discussion about broken image links and questions about markdown vs html, and it seems to now be going into some question about being unable to save journal posts…

so let’s break things down:

  1. earlier, i noted that you were using an invalid anchor close tag. it’s not clear to me whether you ever fixed the invalid tag, and whether that fixed your original paragraph separation issue. did using a valid close tag resolve the paragraph separation issue?
  2. tiwane noted the issue about image URLs changing, and you confirmed that you understood the issue here. so this seems to be resolved.
  3. you can’t always mix html and markdown in the same block. if you’re going to do markdown in a particular block, then do markdown. if you’re going to do html, then do html.
  4. it would be helpful to see screenshots of “greying out and strike through of the Save button for the editing of posts”.

My earnest apologies @pisum. Yes, I unpublished both for a while as I had made test changes that made them appear even more incomprehensible. They are now published again. Here are the links in case they have changed:
The Journal Post referenced in the original post here: https://inaturalist.nz/projects/auckland-renh-kaipatiki-creek-trial-umbrella-project/journal/31715-final-report
https://inaturalist.nz/projects/gahnia-grove-site-summary-and-discussion/journal/37415-methodology-trial-report-for-year-two

Indeed. An excellent summary of my present experience.

Well this problem is affecting my ability to test changes. If anyone knows a possible reason for posts not being able to be saved it would help streamline my testing and reduce one strand of the aforementioned indecipherable mass:)

Helpful, thanks. Now I need to learn which parts of my posts are html. Everything I did prior to adding Lists and the Contents section, presumably? eg image links, links to iNat projects and Observation sets…so I will now go through those and remove any a href closing tags.

Next time I get the greying out of the Save button I will screenshot it.

Thanks!

Splitting up the Gahnia Grove Post (2nd link) into separate posts

eg
https://inaturalist.nz/projects/gahnia-grove-site-summary-and-discussion/journal/55631-methodology-trial-year-two-kikuyu-management

https://inaturalist.nz/projects/gahnia-grove-site-summary-and-discussion/journal/55634-methodology-trial-year-two-weed-controlresults in restoration of much of the intended appearance

Update- have made some changes to the Final Report post and have restored bullet points, by replacing what looked in the Edit page like a bullet point (html? did I create these with a button in iNat?) with hyphen followed by space

in this combined Gahnia Grove journal post, the first point where formatting starts going awry is a spot where it looks like you’ve created an anchor point but have not closed it. add the close tag, and things from that point should look better:

for this journal, the first spot where formatting starts going off the rails is near the “NB Maximum” block. i think you’re intending this to be a second paragraph within the point #2, and i assume you’re trying to use markdown to achieve this, but i don’t think you can do this. try making the whole thing one paragraph instead of two paragraphs, and see if that fixes things. alternatively, make the second paragraph a sub-bullet by adding a couple of spaces at the front, and see what happens.

if there are still issues after editing that bullet, it would be helpful to see how you’ve drafted/coded the section between “Some locations are named…” and “The methodology’s attention to species identification…”. it looks like there may be multiple issues in how you’ve coded it, and it’s hard to see the full picture by just looking at the interpreted/resulting page.

a screenshot or two of what it looks like in Edit mode should be able to shed light on whatever the issue is in that section.

Thank you very much pisum. I have been working through the Gahnia Grove report with that info, closing anchors, and found a couple of unclosed italics, with much improvement. The paragraphs are the main thing still missing after this work.

When I have finished working through that report with what I have learned today I will address the other one, se what happens, and report back.

But first a cup of tea and a lie-down, and maybe another day or more, depending on external events, before I complete this.

Its not possible to screenshot it as it disappears when cursor moves off the button, but it seems to be a temporary thing usually followed by saving. Perhaps I unknowingly try to click it twice, due to the delayed response, and of course the 2nd try is refused.

It did not. I found a few invalid closing tags and fixed all that I found. The paragraphs are still missing in https://inaturalist.nz/posts/37415-methodology-trial-report-for-year-two.
Everything else is much improved, thank you pisum.
Starting work on the other one now.
Update: fiddled with those changes you suggested, not really important so I settled for combining sentences.
Any issues visible in this screenshot?

or the next bit? This is where problems escalate: