Metadata from Google Photos not importing (Android)

I have the same problem too. Google Photos automatically uploads photos from your phone to its cloud. You can then choose to have Photos remove all photos from your phone that it’s ‘safely backed up.’ When I upload photos that are still on my phone, [most of the time] all the info appears. When I have Photos remove the photos first, then try to upload, all of the data is missing and I have to manually input it. The app has all the permissions and I’m pretty sure that I don’t have ‘Remove geo location’ checked- after I remove the photos from my phone, they still have the time and location on Google Photos (both web and app).


On certain Android devices (such as the Pixel), Google Photos is the gallery app for both photos stored on the smartphone as well as those photos which have been moved to the cloud. The reason I’m mentioning this is that whilst for Google Photos users, the steps required to Share an image with iNaturalist are the identical whether the original image is on the phone or Google Photos servers, different processes are occurring in the backend

1 Like

This setting is set to OFF

Yes, iNaturalist app has full permissions

I just thought I’d follow up on this: I’ve noticed that location information from the photos in Google Photos seems to not transfer to iNaturalist when Google Photos reports that the location is “estimated location”, which I guess, means that it is an approximate location, derived from triangulation using cell phone towers and wifi hotspots, I guess.

I have found the location of photos marked as “estimated location” within Google Photos to be quite inaccurate, ie, +/- 1km or more, in some cases.

This might be why the location doesn’t transfer across for these photos.

I’ll keep you posted as I learn more.

This is 100% true:


I think that is a separate issue, though. Even if the photo has a [non estimate] location, as long as it is not on the phone, the location won’t import.

1 Like

I’m not sure if this is a bug, or some feature that I’m not fully understanding - but for the past year or two autofill has been working fine. Over this past weekend I took a few hundred photos in an area where I had no cell service on my phone, but the images still have the GPS tag and time so I planned to upload them later when I got home.

I uploaded maybe 2 dozen of the photos and the autofill of the location / time worked as expected - but then for whatever reason - I started getting to certain unaltered photos that wouldn’t autofill the time / location in the Android app. Downloading those images on my computer and using a browser interface to upload them worked as I expected and the autofill was populated. I’ve only found this issue affecting photos taken that one day so far. Photos taken today are autofilling correctly.

Assuming I have a strong internet connection, are there reasons that I don’t understand that would cause the app to fail to autofill the Time / Location? e.g. Is there some metadata flag that gets set when there is no Cell service that prevents iNaturalist app from auto-filling?

1 Like

Just wanted to add this further observation that I discovered this afternoon - The photo fails to autofill properly when I try to import it from Google Photos - however if I download the photo to my device, and upload from a folder using the android app - the fields autofill properly. So this appears to be (for me at least) an issue with autofill with imports from Google Photos

Google photos is how I’ve imported 100% of my photos in the past however, so I’m unsure why it’s failing in this circumstance.

Thanks for following up with more information. It can also often be helpful to list the version of the iNat app that you are using as well as screenshots, such as the photo metadata in the Google Photos app.

It sounds like this might be a duplicate of an existing report: ?

I just tried taking a photo with location turned on, then opened the Google Photos app and shared it to the iNaturalist app. The date, time, and location all filled correctly.

I looked for an older photo, one that wasn’t on the device, but that I knew had GPS coordinates (I put them there manually from a separate camera), and I imported that from Google Photos into iNat. The date and time came through, but the location did not.

This was on a Pixel 3 using version 1.17.1 (390) of the Android app.

I’m also on a Pixel 3 using version 1.15.2 (387). I’m not sure why I don’t see the 1.17.1 version available as an update unless I have to download it manually somewhere?

I would agree that this question now does indeed seem like a duplicate to the one you linked. I think I may be encountering this bug all of the sudden because after uploading 24 or so observations, I took a break and in the interim I think I may have inadvertently “Freed up space” by selecting to remove photos already backed up to the cloud. Then when importing subsequent photos from that day, the time / location wasn’t being filled properly as described in the link you provided.

1 Like

I’m in the beta testing program, if you’re interested you can opt in here:

I’ll merge these two topics. Hopefully it’s something that can be addressed on iNat’s side and isn’t stuck on Google’s end…

I don’t know if related, but when I use the Android app on my Samsung Galaxy S7, and import local photos, sometimes the location is not imported. Then, if I open iNaturalist with a web browser, go to that same observation, hit edit, then simply check the sync box next to the photos, then save, often it will find the location, but not always.

1 Like

I might add that this may not be a problem with iNat. When I’ve had significant problems with this I found this to be the explanation:

When GPS signal is not available, Google approximates your location from your Wi-Fi and cellular connections.

In Google photos, if you click on a picture, go to info/properties etc to find the location of your picture on the map, if Google has indicated that location is approximate, it means that no geolocation data was embedded into the metadata for that photo when it was uploaded.

Google only offers this location approximation for the purpose of viewing the location on the map (etc). If you download or export these photos into another app from Google photos, Google photos will not embed their “approximation” data into the photo. They will return the photo back to you with same/similar metadata to when you uploaded it (ie, with no geolocation data).

The same goes for if you try to download/export an image that Google has “optimised” ie, they did some sort of post-production processing to the photo. I believe the geolocation data will not be embedded into the photo.

(Side note, it is possible to give your photos geolocation data using Google’s approximate location data, en mass, but it is requires a long explanation for how to do it, beyond the scope of what we’re talking about here. Message me if you want to know how to do it. This is useful if you want to retrospectively put geolocation data into your photos, using Google’s location history data)

One other aspect of this which may be relevant:

  • if you free up space from your phone by deleting photos which have already been uploaded to Google photos (there is a function which does this in Google Photos), but you do it before all your observations have properly uploaded/synced in iNat, it seems to cause a range of problems with the observations, but I haven’t been able to identify a consistent pattern to the types of problems so far.

I’m not an Android user, but I’ve seen this cause some issues. It does make you think that the photo actually has GPS data embedded in it, but Google just uses all the stuff they know about you to estimate the location in Google Photos.

Sometime in the past year or so, Google made it so that unless the actual full photo is on your device (not just backed up on Google Photos or another cloud backup service with a thumbnail on your device), apps can’t access the GPS coordinates of the photo. So you have to download the photo and save it to your device in order for iNat to read the coordinates.


That hasn’t been my experience. If the photo was uploaded to Google Photos with true GPS data, then you can download the image again and it will have the geolocation embedded.

The circumstances where location data will not be embedded in the image downloaded from Google Photos include:

  • the original photo did not have GPS data embedded when it was first uploaded
  • it is not the original photo (ie, it has been edited, or it is a screen-shot of the original, etc)

Assuming this is true, this is a very important issue. Do you have a link to where Google explained this change?

Why don’t you simply present the photos hosted by Google in an embedded frame on iNaturalist? Wouldn’t this be easier than depending on user’s device to act as the intermediary in the file transfer process?

It has been for me, though. If the photo isn’t on my phone, and I don’t redownload it before making the observation, the location won’t import.

1 Like

I just discussed this with our Android developer. Here is why we download a save a local copy.

  1. We basically save a local copy of it, to the app’s cache directory, since we need to resize it before uploading it.
  2. When you scroll through the obs list, we can either show online photos (=already uploaded) or local photos. Linking to Google Photos in the obs list, while you scroll, doesn’t work. We save those cached photos both for speed (loads faster) and for making them available while you’re offline.

And as mentioned in your other topic, iNaturalist uploads the photo (or a resized version, at least) on our servers. Otherwise, if the photo is deleted from Google Photos, it won’t be viewable on iNaturalist. This is what happened with our previous Flickr importer many years ago.

As for the location metadata issue with Google Photos, I assure you this something we looked into, because it’s certainly not ideal. I just did re-testing, and the only way to get location data from a photo in Google Photos is to:

  1. Tap on “Save to device”.
  2. Within Google Photos, share the photo to iNaturalist.

Is there a suggested workaround for those of us who prefer using a desktop to upload?