Location and time don't autofill when importing from Google Photos

I’m not sure if this is a bug, or some feature that I’m not fully understanding - but for the past year or two autofill has been working fine. Over this past weekend I took a few hundred photos in an area where I had no cell service on my phone, but the images still have the GPS tag and time so I planned to upload them later when I got home.

I uploaded maybe 2 dozen of the photos and the autofill of the location / time worked as expected - but then for whatever reason - I started getting to certain unaltered photos that wouldn’t autofill the time / location in the Android app. Downloading those images on my computer and using a browser interface to upload them worked as I expected and the autofill was populated. I’ve only found this issue affecting photos taken that one day so far. Photos taken today are autofilling correctly.

Assuming I have a strong internet connection, are there reasons that I don’t understand that would cause the app to fail to autofill the Time / Location? e.g. Is there some metadata flag that gets set when there is no Cell service that prevents iNaturalist app from auto-filling?


The app is buggy for me. It seems several people occasionally have the issue where the date or location of observations get lost when they go to upload. I just try to check if my observations are in the needs ID pool periodically. It would be awesome if this got resolved.


5 posts were merged into an existing topic: Metadata from Google Photos not importing (Android)