Observations stick with obscured locations

#1

Some of my observation’s location is set to obscured even though I uploaded them as open. I tried changing them to obscured and then open and they are stuck in obscured. I tried changing then to private and then back to open and they now got stuck in private.
Stuck in private: https://www.inaturalist.org/observations/22952136
Stuck in obscured: https://www.inaturalist.org/observations/22097389

I just re-uploaded one as open to test and it automatically went to obscured.

I tried uploading the photos without and ID, and then I ID’d as Forpus coelestis the locations automatically changed to obscured.

Why is this happening?

#2

The “stuck on geoprivacy=private” might be a bug, but for the one you just re-uploaded, click details, and it says:

It is being obscured automatically due to being a CITES Appendix II species:
https://www.inaturalist.org/taxa/19066-Forpus-coelestis

Are you saying that even when you are logged in, it appears obscured to you?

1 Like
#3

Oh this makes sense, just noticed it was a species problem (as I just edited the post).

I don’t think it’s necessary to obscure this species in this location, as it’s introduced and not threatened here. But it makes sense to do it in its natural habitat, as it’s trafficked. Thanks!

1 Like
#4

If the species should not be obscured in that location, you can flag it and it should hopefully be updated. I believe this same issue came up in New Zealand with a species that was rare elsewhere but introduced - and maybe even invasive - there.

#5

Yep, was just in the middle of making a flag. Let’s continue the conversation about that taxon at the flag.

As far as the “stuck on private” observation, looks like you deleted it?