Photo location tags no longer uploading on Android app

Quick summary… I first downloaded the iNat app onto my LG phone, it worked fantastic. Upload the pic into an observation, and all locality and time data auto-upload. Something happened several weeks ago and it no longer does this for location (usually still does for time). I don’t have a screen shot or URL, but I can get one if you tell me what screen is appropriate for it. I’ve trouble-shot my phone settings and everything appears to be in order; my photos on my google account all have locality data attached (from GPS + Network).

Please let me know if I can make a correction somewhere; as manually entering the locality each time might end my iNat use due to lack of convenience :(

The most useful thing for us would be a copy of the photo you’re trying to import so we can verify that it has coordinates and they’re in a format the app will understand. If you’re importing photos from your Google Account, it’s also possible Google is limiting access to coordinates, so please let us know if you’re trying to import photos from Google Photos, whether those photos are accessible locally (e.g. can you import them in airplane mode), and whether you took those photos on your phone or uploaded them to Google Photos from elsewhere.

Also, please always try and include the version and/or build number from the bottom of the Settings view, along with what version of Android you’re using.

Reboot your android device. It always started working again within 24 hours for me (if you did not change the way the made your photos) …

1 Like

Good to know that may still be an issue. My son was using sharing from Google Photos to the Android app for photos taken with a GPS equipped GoPro 7 Black (e.g. and the photos appear in the app edit screen with a blank location field. Note that the photos are locally available, they were loaded from the GoPro to an SD card that was then inserted into his Motorola G6 Moto which has been updated to Android 9. The phone is doing the synching to Google Photos. In Google Photos the photos are geolocated, thus there is geolocation data apparently extant in the original image. Either the data was stripped out by Google on export or perhaps the GoPro7 uses some sort of custom geolocation EXIF tag that Google mapping can read. This is somewhat tangentially related to, although that was specifically referencing the web site.

I advised him to try importing photos from the SD card using the iNaturalist app rather than sharing from Google Photos, and he will be trying that. He noted that the number of images he has makes using Google Photos sharing easier.

Please pardon that this may not be on topic for this particular thread.

Again, what we need to see is the actual file you are importing to the app, not the URL of the photo on iNat (though that might help too). For example, has no GPS data that I can see, but that’s just the photo we have. That doesn’t tell me anything about the state of the photo before it was imported into the iNat Android app.

1 Like

Perhaps the original photo can be accessed via or, if not, then via That said, I took a look at the EXIF and indeed, there is no location data in the photo file, at least not once downloaded and perhaps not as shared. Yet when the image is viewed in the Google Photos app on the phone, a map is displayed with the correct location of the observation. So that is a mystery to me, but this is not an iNaturalist problem to be solved, this appears to be a Google Photos issue of some sort.

When adding an observation from a photo on the phone’s SD card using the iNaturalist app, if he navigates to the Google Photo menu item and pulls the photo in that way, the location data is stripped out. If he uses a file manager menu item to locate the image, the location data is picked up by iNaturalist. The catch is that the file manager takes a long time to load the images. The file manager is apparently loading the full resolution image. Google Photos loads images much more quickly, apparently using a thumbnail capability to rapidly display the image.

The upshot is that this problem is solved in the sense that one must load the image directly via a file manager and not via the Google Photos interface to the photos even when working from within the app. Thanks for the assistance, I can only hope that this information might also help Ian as well!

1 Like

Can’t make progress on this without the requested info.