Project showing on Android, not on Web

Platform: Android and Web

App version number: 1.26.3 (533)

Browser: Chrome 98.0.4758.80 (Official Build) (x86_64)

URLs (aka web addresses):

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Take photo
Step 2: Share to iNaturalist
Step 3: Update location
Step 4: Select species
Step 5: Add notes
Step 6: Add to joined projects The Dirty Dozen and Wellington old man’s beard sightings. Enter details in observation fields related to Wellington old man’s beard sightings project.
Step 7: Select tick symbol
Step 8: Wait for it to upload
Step 9: On Android, I then see it in 1 project on the observation page. If I edit the observation I can see it is on both projects. On the Web it only appears in 1 project (The Dirty Dozen) and I can’t see the observation fields I entered.

I’m seeing this behaviour on lots of observations.

1 Like

what are some other observations where this is occurring?

i can see that in the past, you have been able to associate observations with the project, with and without observations fields, using both the app and the website. examples:

were these created differently than the problem observation(s)?

sometimes indexing of observations doesn’t happen for some reason, and that can cause observations to look as if they haven’t been updated even though they have been. if you have several of these observations where there is an issue, try making a small change on one of these observations (which should trigger indexing), and see if that makes a difference.

I am having a similar problem. On Android ((1.26.3-533) I make an observation, select my project (I have just 1), fill out the observation field, and check to confirm. If I later edit the observation in the app I see “Projects 1” and the observation field is correctly filled out. But the observation never shows up in my Project page. I have tried several observations with no luck. If I go to my desktop, the observation is there and everything is as expected except that the Project and Observation fields are blank. If I add them in on the desktop, the observation then loads onto the Project page without a hitch.

does the only occur if the project has observation fields?

it sort of sounds like you might be describing the same thing as:

these also sound like they’re related:

Based on pisum’s hint, I stripped down the project, so there are no observation rules and no observation fields. After doing so I was able to successfully make a test observation, select my project, and have the observation appear on the Project list. I conclude that the problem has to do with including an observation field in the project, which unfortunately is the whole point of setting up the project in the first place. I had initially used the observation field “Phenology (flowering)”, but as I test I also tried “Flower phenology”. Neither works. Incidentally, I am using observation fields because I need more levels than the default Phenology attribute provides. Any advice on what to do? Should I be submitting my own bug report instead of piggy-backing on Nigel’s?

if observation fields on projects are the issue, it sort of sounds like the fix for the previous bug report i noted above probably didn’t work or maybe even triggered this problem. @tiwane and other staff may need to revisit.

you might want want to generate some log files from your app when you encounter the problem and send them to iNat staff. do a search for log files in the forum if you don’t know how to do that.

1 Like

Sounds like a widespread issue, added a comment to this bug report on Github.

Ok, I will repeat the test – project with and without an observation field – and send in my own bug report with some log files included. (Later this evening).

1 Like

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):

App version number, if a mobile app issue (shown under Settings or About):
1.26.4 (534)

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I initially described this problem as an addition to a bug report by nigel_charman. Because the issue seems distinct I am now submitting my own bug report.

Step 1: Make an observation on Android.

Step 2: Select the Plantwatch project and the associated observation field.

Step 3: Submit the observation.

After these steps, I can view the observation via the iNat website, but the project and observation fields remain blank (see Screenshot 1). However, if go back to Android and edit the observation there, the project and observation fields seem active (see the other 2 screenshots).

I borrowed my wife’s iPhone and had no trouble adding the same test observation to the Plantwatch project on that platform. There is also no problem if I use the website.

I also edited the Plantwatch project and removed the observation field. Upon doing this I was able to successfully add the test observation to the project using Android. Therefore, there is something about including an observation field that is triggering the error. Note that, in the project setup, the observation field was not set to “required”.

I will email the two log files that were generated after the last batch of tests (from

(moved the above post to this topic to consolidate them as it appears to be the same issue)

Sorry for the delay in responding. I only just noticed the responses.

The first of those 2 observations you have mentioned would have been created in a similar way to the problem observation. The second one was probably created on my web browser.

I’ve added 2 observations on my Android phone tonight:

I added both of these to 2 projects: The Dirty Dozen and Wellington old man’s beard sightings.

When I check on my browser, neither of the observations are in either project (but they have been added to a couple of collection projects). Editing the observation on my mobile, I can see they are in both of the 2 projects above. (Even though I change nothing when I edit it, and just click the left arrow to go back, it still uploads the observation when I have finished editing it.)

This is different behaviour from that I saw the other day where it was added to The Dirty Dozen.

The Dirty Dozen project doesn’t have observation fields, but Wellington old man’s beard sightings does.

My app and Chrome versions are the same as my report above.

Note that there was something else strange. When I entered, after clicking Add to project(s), the list of projects on Select from Joined Projects was empty. I proceeded to enter this observation with no projects and then edited it to add the projects.

Entering the subsequent observation, my projects appeared on Select from Joined Projects so I added it to the 2 projects on my initial entry.

I’ll send my log files in. Thanks for your help.