Trouble with geographic coords on iNat app on Samsung Galaxy S7 Active

Platform (Android, iOS, Website): Samsung Galaxy S7 Active

App version number, if a mobile app issue (shown under Settings): not showing up under settings, redownloaded 24 Aug 2020

Browser, if a website issue (Firefox, Chrome, etc) : N/A

URLs (aka web addresses) of any relevant observations or pages: N/A

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): Any new observations will not attempt to find the geographic location, pressing the “target button” on the map leaves the dot at 0, 0. Must manually enter the coordinates in. Previously iNat worked just fine on my phone.

Step 1: I’ve reinstalled iNat twice

Step 2: I’ve rebooted my phone twice

Step 3: Location is “on” on my phone, all other software can access it, I’ve also toggled it on and off.

Any help is much appreciated, it has been frustrating to troubleshoot.

https://forum.inaturalist.org/t/android-app-version-1-20-10-doesnt-access-location-data/15620/12

That being said, I’ve upgraded to the version they say fixes it, and still not working for me.

2 Likes

Jason, looks like they moved the app version number to underneath “About” instead of Settings on Android.

2 Likes

Thanks @bouteloua, that’s exactly where it is.

@cmcheatle, thanks for the link, sounds like that is the same problem I am having. I have version 1.20.11 and it is still not working for me too.

2 Likes

In all such cases I would first check the GPS status itself. It may work quite tricky in Android.
Use the free ‘GPS Status & Toolbox’ App. It allows to test GPS thoroughly, and to choose the GPS source explicitly. It also allows to reset A-GPS data.
Make sure your device not only can see the satellites, but also ‘fix’ to some of them.

1 Like

Thanks, I did download that app and it didn’t help. As of yesterday it was still not working however I just checked and now it works. Not sure why, I did nothing.

If it works, then the app might have actually helped. AFAIR, it should reset GPS automatically when you start it. Try changing the GPS-data source (in the menu).
Avoid any confined space when doing this.

I am pretty sure this is the bug we had with version 1.20.10. We released a fix very soon after, so I think what happened was that you were running 1.20.10, experienced the bug, made this report, and between then and when you checked the version number on the About view the app was updated to 1.20.11 (which fixed the bug), either b/c you manually reinstalled or it automatically updated.

The Play Store is a bit weird about what version it installs when you reinstall. I reinstall a lot in order to test different versions I often find that when I install something from the Play Store and then return to the app in the Play Store I immediately get an option to update the app… that I just installed. Is there a moral to this story? I don’t know. Beware stores bearing versions? Install twice, run once?

3 Likes