Url for Project acquired extra characters

I don’t know if this is a bug or just a one-off thing that has occurred.

MacOS10.4.6 Mpjave

Some of my Project urls acquired extra characters quite a while ago, and this makes it very inconvenient to give people the links verbally, or to write them out by hand on signage so the public can look them up on site.

eg the Umbrella Project
“Tanekaha Ridge, Eskdale Forest, Auckland”

now requires the url

If the characters after “auckland” are not included, the link goes to a different Project:

as seen by following this link:

which is also mine, and covers the same geographical area, but has a different function.

Most of my Projects do not have this issue.

If this is the result of characters used in the Project name, please let me know what needs to be changed.


Could you try getting rid of the commas; either entirely or replacing them with say dashes, and see if that fixes it?

1 Like

Thanks I will try that. Not this morning (as when the address changes I will have to send the new one to some of the agencies involved in cutting down trees etc to make a bike track through the forest…and this morning I am going there to take photos, not into admin) but soon.

1 Like

I would hold off on giving out the new address/name until you check whether the problem persists

1 Like

When I removed the second comma and the word Auckland the problem was corrected, ie all those extra characters disappeared from the url.

However, another Project has the same name format, ie
and does not have this problem.

Also some other Projects acquired extra characters in the url some time after I made them, I can’t remember which at present.

Ideally I will not have to change Project names from time to time because of code problems arising ad hoc.

So could someone look into this @tiwane?

I had a problem with a Place name once, and a curator was able to fix it by changing the name then changing it back again, in some way that I could not. Is there such a solution for this issue?

No need to @ Tony on new bug reports - he checks through them regularly.

There isn’t a URL “slug” editor field on collection projects like there is for places. Also, curators can’t edit other people’s projects.

1 Like

Thanks. I was concerned it might be missed because there is a checkbox showing it as Solved.

I don’t want to change the name of this Project without knowing what the problem is.

1 Like

I’m not seeing anything marked as solved here (or maybe you unchecked it?). if the bug report is still open, it will be looked at eventually. :)


I have been seeing, and still see, a checkbox named Solution, checked.

1 Like

try refreshing because I don’t see it either


It is still there. Perhaps it is an option in case I wanted to add it? It is pale grey , but so much of the internet is low contrast these days I have learned to pay attention to pale grey:)

Yup, thAT was it. I tried selecting it and it went bright coloured. Ok, thanks for the lesson:)

1 Like

Still likely to be attended to, do you think?

not sure if anything was done to address anything here, but i think this URL works for the umbrella project (took off the -auckland): https://inaturalist.nz/projects/tanekaha-ridge-eskdale-forest.

i haven’t really investigated why https://inaturalist.nz/projects/tanekaha-ridge-eskdale-forest-auckland still redirects to https://inaturalist.nz/projects/tanekaha-ridge-summary, but i’m not sure it’s worth investigating if the first URL works.

@kaipatiki_naturewatc – if the first URL works, do you think there’s still something that needs to be investigated here?

I need to refresh my memory re this

1 Like

ok. great. if you wouldn’t mind, please mark one of these posts as the solution just so that it’s clear that this bug report has been resolved. (otherwise, we’ll need to bother a moderator to close the thread.)

Wassup. Not bothered at all.
If the thread needs to be reopened just let a mod know