When using Google auth, each login requires repeat consent

When logging into my iNaturalist account using my Google account, I always get asked for consent for iNaturalist to access my Google Account. I always click ‘Allow’.

This wouldn’t be too annoying, except that each time I authorize this, I get a notification on my phone and in my inbox checking the activity.
Also, I cannot use Google Photos within iNaturalist.

iNaturalist should not need to be reauthorized every time I authenticate.

Things I’ve tried to resolve it:

  • Unlinking my Google account in Account Settings, and relinking it.

Other information:

  • I orginally setup my account against inaturalist.com, but switched over to inaturalist.nz
  • I am also authenticated against my Google account on the inaturalist andriod app without any issues.

I too, am having to repeat permissions. I tried to unlink my account from google but didn’t manage it because a user (i.e. ME) already existed with that iNat email. I have just been enduring the repeated permissions and confirmations as my iNat data is too valuable for me to lose because I mismanaged it somehow. I will state that when I log on the android app with my phone it both requests and sends verification on the device.
I had been approaching it from the standpoint that somewhere, something in my google permissions was awry. I have reset and double checked these multiple times. Otherwise, I have just been tolerating it. If someone could direct me as to how to fix this I would be eternally grateful!

Duplicate of
https://forum.inaturalist.org/t/not-remembering-me-when-i-log-in/2426

Mods can perhaps merge

I think they could stay separate since that user indicated they log into iNat using a username and password rather than Google.

Pretty sure this cant be fixed, Google has pretty much locked out any external sites from using content at Google Photos, for example bbcodes wont work etc.

1 Like

That’s true for me as well, I just did not note it on the other thread as it did not seem relevant to the core issue of constantly having to authorize a Google login.

Is this still happening for you?

I’ve switched to using username + password instead of SSO through Google, so I’m not sure if the behaviour has improved with Google auth.