Batch Edit Add to Project doesn't work

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): N/A

Browser, if a website issue (Firefox, Chrome, etc) : Firefox 90.0 , Chromium 94.0.4606.71

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations/albyp, https://www.inaturalist.org/projects/botanical-society-of-western-pennsylvania

Screenshots of what you are seeing: Batch Edit Add 10 images to Project:


Project Page After Adding:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Go to Edit Observations Page

Step 2: Filter out a set of observations using “search” button

Step 3: Select All observations.

Step 4: Click Add to Project: Botanical Society of Western Pennsylvania

Step 5: Go to project page, and see none of observations were added.

**When I Manually added individual observations to project to confirm they fit the criteria they all showed up.

2 Likes

Same thing here, with Microsoft Edge and trying to add to the project “Belgium biodiversity”.
It’s the first time I use this method.

I was able to replicate this and filed a github issue: https://github.com/inaturalist/inaturalist/issues/3262

3 Likes

Thank you!

1 Like

I have just tried to do this myself, to add two observations to a project. When the page refreshed after I selected the project, instead of taking me back to “Edit Observations”, it took me to an “Identify” page, with "You are already signed in. " in a box across the top of the page. The “Identify” page is probably something I have looked at in the past, but not recently:
https://www.inaturalist.org/observations/identify?page=7&iconic_taxa=unknown&created_on=2020-07-17&createdDateType=exact

I’m having the same problem. It takes me back to my Dashboard. I check my observations and check my project. Nothing got added. I’m using Firefox on my PC.

1 Like

Same error here on chrome and firefox.
I use this tool all the time so it is a recent glitch (within the last 5 days or so).

You can still manually add the records from the individual record page, so only the batch editing seems to be down.

1 Like

Yes, I no problem adding them from the individual observation’s page. No problems with adding during upload either.

Same issue for me. Worked fine about two weeks ago. Can add to a project on the observation itself, one at a time, but that’s not gonna work if I want to make a few more observations this month. :-)

Why can I no longer use Batch Edit to add groups of observations to a project?

A process that I have been using successfully for a long time has recently stopped working. From my https://www.inaturalist.org/observations/jayras page
I would select the “Batch Edit” button, select a set of observations and then select “Add to Project”. No observations are added to the selected project and
instead I simply wind up at https://www.inaturalist.org/home. For the time being I am loading each observation separately and from the observation page I
am adding it the desired project(s). What is the method that I should be using to batch add observations to projects?

Thank you!

As noted in this thread, this is a bug - it’s not intended. Our developers know about it and will investigate when they can.

The fix has apparently been made and will be implemented soon.

1 Like

Platform: Mac OS High Sierra
Browser: Safari 13.1.2

Problem: I add existing observations of mine to projects periodically. I recently tried it, only to find the workflow broken at the final step.

Step 1. Go to Project page
Step 2. Click Add from Your Observations link to the right of the map
Step 3. Click Batch Edit and select desired observations
Step 4. Open the Add to Project dropdown

That brings us to the screenshot below. When I click the Add button next to the project name, I get a quick redirect to the iNat home page, sometimes with a banner saying “you are already signed in.” The observations are never added to the project. This bug occurs no matter which project I’m aiming for and no matter how many observations I select.