Batch Edit Save Gives Error

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): n/a

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages: (insert long character string for a batch edit page)

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
Edit Observations > Search parameters selected > Select All > Batch Edit > set new privacy as batch > apply all > wait until screen stops loading, and last one on the page shows new privacy > click “save” > get above screen shot.

Attempted a couple times, and tried also just selecting like, two, observations (without using the search feature, just selecting two on the edit page), same error.
ETA: Apparently if I select by animal type in that checkbox list, AND it is less than 30ish, I can do it. If I select by animal type and more than 30ish observations, I get a 504 Gateway Time-out error. Doesn’t seem to work without selected animal type as well, so…weird.

Batch edit is pretty old, and it’s definitely negatively affected by the number of observations being edited. In me experience I’ll get a time out but the editing will eventually happen to all the observations. Have you double-checked to see if this is the case at all?

I ended up working through it slowly, using the animal type checkbox and only selecting 30 at a time. So they are changed now.

1 Like