Batch edit window does not display batch edit options

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): MacOS on MacBook Air

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): The “Batch Operations” banner for editing a batch of observations does not populate with editing options. I’ve tried refreshing the page, backing out and trying again, but no luck. Is it a Safari issue?

Step 1: Choose “Edit Observations” tab from my Home page (

Step 2: Choose “Batch Edit” and click “Select All” to select 50 observations.

Step 3: Choose “Edit Selected”.

Step 4: As the “Batch Operations” page is loading, some editing options flash on in the yellow panel but then disappear as the page finishes loading. I tried clicking “Batch Operations” to open the yellow panel, but there’s nothing in it. See screenshot.

Update: I tried doing Batch Edit on a different device (iPad) using Google Chrome app. It worked fine. So it seems to be an issue with Safari and/or MacOS.