Bulk edit performance issues

Hello,

I am using:
OS = Windows 10
Browser = Chrome

Tried to bulk edit my observations but it seem does not work with >10 abservations, which is very small number I have >4k to edit.
How can I workaround this?

The options are limited to the set 10,20,30,50, 200. With 50 and 200 I am just having a timeout error.
20 and 30 are not tried, the option 10 works but its very slow.

Being honest even 200 is a small number and I would need 20-25 iterations to have my job done. But still…

Thanks in advance.
Ani

2 Likes

I also would like increased numbers to be able to be edited at once, and currently use only 50 per page due to the high rate of failure with Timeout error as mentioned above, for 100 or 200 obs.

I don’t know if more complex edits - eg involving several Fields, or particular fileds - affect this performance.

The timout error message often appears despite the obs having apparently all been edited, so it pays to check what actually happened. And to be aware that those obs just updated will not show the edit in the thumbnail in the Bulk Edit page for some time (hours?) despite refresh, so you have to open one to find out if it is edited.

3 Likes

Hi kaipatiki_naturewatc I have used inat forum much; hopefully you get this message, and can reply to me. This bulk editing problem: did you resolve it? I am having the same problem, since I began using iNat a few years ago. It is driving me nuts. I want to bulk edit geoprivacy for many of my observations, but the timeout problem happens, plus it seems after I change geoprivacy (for example, from ‘open’ to ‘obscured’) then pressing ‘save changes’–that the changes never happen. Anyone that can help me?

1 Like

Hi rudygelis. I don’t notice the timeout message anymore; as i said above, the edits have usually happened.
There are some things I can’t bulk-edit, or not consistently. Changing Accuracy to 0 is one; the original accuracy often just appears again after having been either deleted or changed to 0, and Applied.

Most changes, for those Fields available in bulk editing, do work.

I haven’t tried the geoprivacy setting as I don’t use it.

I believe the site is being overhauled - is that still going on, anyone? - so we may see some improvement when that has happened.

1 Like

I get the timeout error, but my edits are usually always applied when I go back to my observations and refresh. If you have a situation we can try to replicate where the changes are not applied, please let us know here and provide a set of steps we can follow to replicate it. I made a bug report here: https://github.com/inaturalist/inaturalist/issues/2709

The site isn’t being overhauled, but we are revamping certain older parts of it, like notifications (this will take a while) and life lists. Batch Edit also needs to be revamped as it’s quite old, but it’s not on the immediate plans.

2 Likes