Can't flag images for copyright violation via an observation's overlay page

Platform (Android, iOS, Website): Windows 10 19042.928

App version number, if a mobile app issue (shown under Settings or About): N/A

Browser, if a website issue (Firefox, Chrome, etc) : Firefox 87.0 (x64)

URLs (aka web addresses) of any relevant observations or pages:
https://inaturalist.nz/observations/74462868 - but any observation will do

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

  1. On the overlay of the observation there are no icons for copyright flagging, etc.

  2. On the Flag As Inappropriate link on the Data Quality tab, there is no option to flag for copyright.

  3. On the main observation page, the icons exist correctly.

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: From the Identify page, left click on any observation. The observation overlay opens, and there are no icons on the picture for information, copyright flagging, etc.

Step 2: From the Identify page, right click on any observation and choose Open in New Tab. A new tab opens on the observation’s home page. The information & copyright flagging icons are visible.

Therefore it is only possible to flag for copyright violation from the observation’s home page. This is inconsistent and reduces the usefulness of the overlay view.

NOTE THAT THE URL USED AND SCREENSHOTS SHOWN ARE NOT IN VIOLATION OF ANY COPYRIGHTS - I JUST USED IT AS AN EXAMPLE :)

Hi Russell, welcome to the iNat Forum! The Identify page hasn’t been designed to flag photos. The Identify page shows limited information and there are several actions that can only be done by visiting the observation detail page.

2 Likes

I see. An interesting design choice. Thanks for letting me know.