Can't unset an observation field

See e.g.

I added an observation field Sequence Flag (after adding the observation to a project that uses that field). Now when I edit the observation, I can change the value of that field, but if I try to unset it, the previous value reappears!

Also, for some reason I get a notification that I have edited my own observation when I change the value of that field…

What exactly do you mean by “unsetting the observation field”? Do you simply press backspace until the field’s value is fully erased (which when confirmed with the enter key would make the value you just erased reappear, as programed), or do you delete the observation field itself? As for being notified when you modify your own observation field, it’s happened multiple times to me as well. Couldn’t tell you whether it’s a feature or a bug

Out of curiosity, when/how have you been filing in the Sequence Flag observation field?

The project I run has 2 drop-down observation fields (1 mandatory and 1 optional) and we’ve noticed that at least the iOS app automatically adds the 1st drop-down value of the optional observation field when adding observations to the project. Neither I nor the original observers have been able to delete those observation fields, which leads to contradictory data:

(Moderators: Can I include the link to this observation here? I know there are rules about linking to other people’s observations, but I’m not sure how well troubleshooting will work if I don’t give an example of an observation where the field can’t be deleted.)

However, when I create a troubleshooting observation through the iOS app, I can see where to delete the contradictory optional observation field:

I’ve had repeated discussions with various people about this and none of them have seen a “Delete” option when they click on the Observation Field name, so I think it is some sort of technical issue.

Yes, I just backspace the contents of the observation field (or click the x inside the field to clear the value). Then when I save, the value I just removed re-appears…

I don’t see an option to remove the field itself. Maybe it’s required for this project? If so, shouldn’t I get an error when trying to save?

I’m using the web app, and haven’t tried editing the observation in the mobile app.

When you click on the name of the observation field on the website, does the “Info” pop-up that you get just have “Edit” like the 1st screenshot I posted?

Yes, and looks like I can delete the observation field from there!

I was trying to remove that field by editing the observations and clearing the field in the More Fields section. And when I do that, the value just reappears after saving.

So you were trying to remove the field through the Edit Observation page? Interesting. Does clicking the blue X in the window just get rid of the edits?

Yes, clicking the x clears the value of the field (until you save…), but doesn’t remove the field itself.