Comments and ID's fail to submit on Android app

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android 6.0

App version number, if a mobile app issue (shown under Settings or About): 1.24.0

Browser, if a website issue (Firefox, Chrome, etc) : Not applicable

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Open the app

Step 2: type a comment/add an ID even without a remark

Step 3: it will not work

I tried on multiple observations.

I was replying to a message by @tiwane but it didn’t send, so I thought there was some kind of admin exclusive tag mute function, when a message without a tag didn’t go through I wondered if it was a problem with the observation, but others failed too. I suspected account problems, but all above activities worked just fine on website (including that tagging bit).

No comments nor ID’s can be added through the app. Observations upload as normal.

yup. i can confirm that i could not add an ID or comment to an observation in the app even after i logged out and logged back in (v1.24.0 on Android 11). adding an ID on the same observation in the website works fine. adding annotations in the app works, too. might be related to some recent security changes?

1 Like

though I am sad this is a bug, I am glad you posted, so I know that it isn’t me. I went so far as to turn off my phone, I thought maybe I had exhausted it, haha. I have Android 10, though, and app 1.24.0

1 Like

Been having same problem as well.
Ver 1.24.0, Android 10

same problem for me, android, galaxy s7, started yesterday

Same here on android, waiting to upload and then gets a 1/4 way through the first observation before failing.

Same here

Could it be this?

Same here.
Android 8, ver 1.24.0

I’ve been experiencing the same issue too. So glad to know it’s not just me!

Even when I just click “Agree” it doesn’t work–just reloads the observation without saving my ID.

Android 11, Samsung Galaxy Note 10, iNat app v1.23.22

Likely the result of of some new code we deployed yesterday, I apologize. We’re investigating now.


OK, this should be fixed. I was just able to add an ID in Android.

1 Like

Yes, working again. Thanks so much