Countries become rectangular when using the Location bar in Explore

This seems like a bug to me, but since I can’t replicate it I wonder if it’s tied to a settings difference somewhere, such as language (as mentioned above), place prioritization, browser, etc.

1 Like

You need to flag it, I mark them as no evidence of organism. There are also duplicated nuthatches, in different poses, but I can’t open them as link is opening weirdly on my phone.
Always use filters if you want right place borders.

1 Like

Hm, okay. Well, I’ll just share some of my settings just in case it gives someone any ideas or if it’s used later for bugfixing, if indeed it is a bug.

OS: Windows 10 Pro 64-bit
OS Language: English
iNat language: Normally Dutch, but switched to English for screenshots, had the same behavior in both cases.
Browser: Google Chrome, version 89.0.4389.128 (Official Build) (64-bit)
Place prioritization: Uh… not sure what this is, sorry.

If there’s anything else anybody would like to know, please feel free to just ask me, and I’ll let you know.

I see, so you just mark all but one of the duplicate observations as such, then? EDIT: I actually cannot find a flag option other than “Flag as inappropriate”, but that seems to be intended for spam and the like.

Oh right, those were actually what I was talking about, but I see the finches now, too. The nuthatch is here, with links to the others in my comment there.

1 Like

Cities also seem to become rectangular or squared, and entire sections of the cities are cut off and observations from those areas that were cut off do not show up when the city is searched.

For example, when I search Keizer, OR, USA in the search bar, Keizer Rapids is not included as part of the city at all. It’s too bad that we cannot type in the desired coordinates into the search bar, then any observations that were uploaded inside of those coordinates show up.

1 Like

That would be cool. Or like a radius from a single coordinate point. You can of course move and zoom the map to anywhere you would like it, and then “Redo search in map” to get a bounding box, but that only allows you to make rectangles of a certain aspect ratio.

1 Like

Just a thought. Not expecting anything to be here if you didn’t know about it.

1 Like

https://www.inaturalist.org/observations?nelat=53.6756&nelng=7.227&place_id=any&subview=map&swlat=50.750&swlng=3.3316

2 Likes

This is possible by manually editing the URL.
https://forum.inaturalist.org/t/how-to-use-inaturalists-search-urls-wiki/63#heading--bounding--area

3 Likes

Oh, thank you. That was set to my local municipality, Loon op Zand. Which makes sense, now that I think about it, as it always starts there. I don’t really want it to, so I just changed it. I just checked, and it doesn’t look like that was related, as the website behavior I described is still the same.

Thanks for the above comments, cmcheatle and thomaseverest, those are very helpful and interesting! Neat.

There are 2 possibilities I can think of.

For me at least, when I enter Netherlands into the search, it initially displays the same box that you see, but then quickly changes to the proper map as the ‘translation’ is done. It is possible something is blocking that refresh on your system

Also Google search results vary depending on where they are submiited from, so the ‘Netherlands’ in my search results may actually be pointing to something different in Google Maps than your search results.

1 Like

Yes, I saw your comments under one set of them, but couldn’t open others, so if you added comments there too, just mark all duplicates, in cases of pics with more species seen iding one of them (also with comment) is possible too.

Oh, interesting. Sometimes I have these sorts of issues with Google Chrome, and I am also using an adblocker on my browser, so it might be related to this. Let me try it now with Edge… yes, how about that! It goes right to the actual borders of the country. (Did not see the bounding box first, but it might just be too fast for that.)

Now let me try again in Chrome with my adblocker disabled. Nope, same behavior. So it’s probably related to Chrome, the browser, then. Thank you! Also, I cannot seem to post any more comments for today (first day being active on the forum), nor hit the enter key when editing this message, so I’ll have to reply further in here for now. Yes, my Chrome is also set to English. In response to two messages down: That is very interesting. It sounds like it might be the case when set to French, right? It might have “Pays-bas” or something. I ask because I am learning French and if I visit Google, the website shows up in French (even though Chrome and my OS themselves are set to English).

2 Likes

Is your Chrome set to English?

I suspect the problem is the same as the one here. In short, something is telling the Google Maps API to return the results in Dutch. I know the OS can do this, as can the browser. In this case, I’m not sure where the message is coming from, but you can verify whether that’s the problem using Chrome’s Developer Tools.

Once you select Netherlands in the Location drop-down, there will be a call to the Google API. If it’s being told to return a result in Dutch, there will be “nl” in the call. Here’s mine when I set the browser to Dutch:

Then, the result comes back with “Nederland” instead of “Netherlands”:

iNat then tries to find a place called “Nederland” and fails (because the iNat place is called “Netherlands”), so it uses the bounding box coordinates instead.

5 Likes

Google’s entire localization is messed up. It simply can’t decide if I am English or Danish. Some services assume English, while other seemingly random ones assume I am Danish and act accordingly.

2 Likes

Exactly! If Google is showing up in French, I would bet that iNat is getting French results, which will also give the bounding box.

I also changed your trust level, so I think you should be able to post again.

2 Likes

That sounds frustrating. There are just so many places to set the language – OS, browser, Google account, iNat – and even just in testing, I continue to be surprised about which ones override which other ones.

2 Likes

Not a big deal, I’m fluent in both, just surprising it is so inconsistent.

1 Like

That must be it, then. In fact, let me try it right now. Huh. So my google.com UI was all in French, but my settings page was all in English, and I did not find a language setting there. On the main page, I could switch it to English, and it seems to remember that between visits to google.com, but it doesn’t seem like that fixes the issue on iNaturalist.

Exactly this.

Thank you, that’s very helpful :)

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.