Fail Whale on Certain Links

Platform: Website

Browser: Chrome

Trying to access certain links just gives a fail whale.
Journal posts, for example:

Fail whale shark also shows up after updating Checklist entries. (Although they do end up being applied. )

Many thanks, both of you, we’ll take a look at these tomorrow. We released a major software upgrade today, and despite quite a bit of automated and manual testing, we didn’t catch everything. Biggest problem so far was breaking sign in via Google in the mobile apps, which should be fixed now.

4 Likes

Also, attempting to reorder photos in an observation now gives a fail whale via Chrome. Via the Android app it appears to go through, but upon refreshing the observation it is back to the original order.

Unsure if this is related to the upgrade; visiting the help page gives me the mole of doom!

1 Like

Not just you, I also get the 404 Not found, they were there yesterday <24hrs ago.

1 Like

I got iNAturalist is down, but the forum was up and nobody noticed…

I am unable to edit any of my observations:
just get the whale shark. Three hours now.
I can duplicate and edit licence, but not edit the observation.

e.g. https://www.inaturalist.org/observations/91453510/edit = whale shark

This one is missing as well: https://www.inaturalist.org/computer_vision_demo

I am also receiving the whale shark page when clicking on Edit at the upper right of
https://www.inaturalist.org/observations/63928073

Trying to re-order photographs also receives ‘Fail Whale’ . :)

Not the fail whale but possibly related to the recent software upgrade. On the taxon edit screen, when clicking on the Refresh Wikipedia summary link an error/info message pops up with raw html. It worked as expected yesterday I think, definitely the day before.

I also get the fail whale when clicking on Edit in my observations ( tried about a dozen different ones at different times in the last 12 or so hours, all the same result)

I just tried to upload some photos from Flickr and got the whale.

I also cannot edit my observations, including previously editable ones. Nor can I delete an observation. Cannot follow the link to followers of myself, brennafarrell, or any user

Safari 14.1.2 (15611.3.10.1.5, 15611) on Catalina 10.15.7

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations/91540622

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): I am consistently getting the “fail whale” when I try to re-order my photos on multiple-image observations this morning - but not when I edit the observation in other ways. I include a link to one observation, but it is happening with other ones this morning too. The only thing unusual about these observations is that when I uploaded all of these images, I accidentally duplicated a subset of them, then deleted the duplicates a few seconds later, not sure if that is related or not.

Step 1:

Step 2:

Step 3:

(merged reports)

We released some fixes a little while ago to address some of these failures. Among the fixes are:

  • The observation edit page should be working properly now (it would have been failing for observations with observation fields).
  • Journal pages should load properly
  • Following/followers pages should load properly
  • Observation photo reordering should work
  • The CV Demo page has been restored

@kitty12 do you have an URL of where you were trying to edit checklist entries? Could you try again and see if this is working now?

Thanks for your patience as we work through any remaining bugs due to a big software upgrade yesterday.

3 Likes

Just received the Fail Whale(shark) when updating a photo license.

Windows 10
Chrome
https://www.inaturalist.org/photos/7546126

I can’t replicate this. What is the URL of the page you’re on, what link / option / button are you clicking, and what license are you trying to switch to?