Filter ATOM RSS feed breaks if you add project filter when using button from project page

If you go to Explore → Filters and set your filters you can use the Atom link in the bottom right to get the RSS feed. Works great, including if you add a project filter

However if you are editing a project and click the ‘Preview Observations with these Observation Requirements’ button to take you to Explore → filters and you add a project slug, it will break the atom link and take you to a 404 not found page. I cannot see any difference in the filters I set manually vs using this button from project page, but it does break the atom link for some reason.

i can’t reproduce this.

it would help to provide for each of your cases:

  1. the Explore page URLs prior to clicking the Atom button.
  2. the URLs after pressing the Atom button

Here is my step by step:

If I just build my filter manually, without starting with the ‘Preview Observations with these Observation Requirements’ it works fine,

Hope that helps.

can you provide your URLs just before and just after clicking the Atom button in this case?


Atom URL:

Its interesting when you follow the link from the project page it says there is 5 filters, but when you do it manually it says one filter with the exact same filter settings.

ok. so the trigger seems to be the combination of filtering for multiple taxa (&taxon_ids=47169%2C48250%2C47685) and filtering for a project that has multiple taxa defined in its rules (&projects=mushrooms-of-pei). i didn’t dig into the code to see exactly what’s happening here, but i guess if we step back a little bit, why do you need to apply a project filter on top of all the project criteria filters? (they’re redundant, since they should be filtering for the same thing, right? you really only need either the project filter or the project criteria filters, not both.)

Yea, that is probably true. Seems like it would save some effort it if just added the project and not all the other stuff. Given the point I assume of the button is to test your settings, using the project has the same effect. Either way, it shouldnt 404.