Filter problem in Identify window

I have had this issue for a while - if I am using the Identify page select a new species, the records displayed change to all records rather then those specified by the filter. To get around it, I have to add or remove another filter (e.g. add a geographic filter or remove a temporal one). I use Google Chrome.


If I go to Identify and search for all records of Least Flycatcher, it works fine. But, if I switch the species to Purple Finch, I get what looks to be all recent Needs ID observations for every taxa. In order to filter to Purple Finch, I would then do something like change the location to “North America” (which encompasses their entire range) and then it will properly display the records I want.

Not a huge deal, but it happens every time I change species in the Identify window which is a bit of a hassle.


I’ve had this happen a few times, but not consistently. Can you please share the URLs that are involved here? It would also be really helpful to see a developer view of “console” in your browser. This page has instructions for how to view the console for the most common browsers:

1 Like

Here’s are two examples:

I followed the instructions for the console view, but it’s blank.

I don’t think the URLs will help much - if I click on the links it brings me to the correctly filtered Identify page.

I have this same issue all the time, and it can’t be “shown” by sharing links.

I’ve had a similar issue (possibly the same issue) where if I change filters a new request is sent to the server for every change I make. Which sounds OK, except sometimes the responses come back out-of-order. So I suspect what’s happening is that you’re removing a species filter, e.g. Least Flycatcher, then adding a species filter, e.g. Purple Finch, but the response with only Purple Finch observations is coming back first, then gets overwritten by the response with all observations.

Getting this to happen depends on having a distant, unreliable internet connection to iNaturalist, plus having the agility necessary to change more than one filter before the first response comes back. Usually the response that takes the longest to arrive is the largest one (i.e. the one with the most observations), so this happens more often if your final change to the filters removes a lot of observations.

As a test, @fogartyf and @mpintar, do you see different behaviour if you slow down?

I have this same issue too, and it does seem related, though I have a very good internet connection.

If I’m understanding the OP’s problem correctly, then this is how I get around it (on the web - don’t know about apps):

Method 1 (recommended)
When changing the taxon name, DO NOT delete it! Click and drag to select all of it and then start typing the new taxon name. This stops the api from loading all obs.

Method 2
If you backspace to delete the current taxon name, DO NOT delete the first letter, then type in new taxon name and go back and delete first letter if it’s not part of the new name (i.e. easier to use Method 1 ;-).

No difference in behavior if I do it slowly - this happens when I make a single change, so no need to slow down. This occurs on very highspeed connections.

This seems to be a work around, but even so it still seems like this is a bug that should be fixed. I can’t imagine the functionality was designed that way.

Yeah those suggestions by karoopixie do not work. And even so, if “speed” is an issue, then it is still a major problem for iNat.

Also, this seems related, but quite often when I type a taxon in any sort of search box it doesn’t return any results related to what I type in.

1 Like

Agreed. If pausing is necessary and there is no work around due to the amount of processing that needs to occur, a good solution might be some kind of busy indicator on the interface that prevents you from changing options until processing is complete.

The current interface has a “Go” button, which I never seem to use because the window automatically updates (or tries to) whenever any filter is changed. Maybe removing that auto-updating feature (or having a toggle to turn it on/off) would be an easy fix? That way you can change all the filters to what you want, then press “Go” without the window repeatedly updating at every change or glitching as we have described.

1 Like