From taxa page, "View All" no longer zooms to extents of range, and pins don't show

As the title states, I go from the taxa page, click on “View All”, and I would normally be taken to the observations (with a place filter of New Zealand from settings) and the map would be zoomed to fit the range of the observations, with pins on the map (assuming of course my last obs list had the map option selected). In the last few days I noticed it started not zooming, and pins aren’t showing. Not sure when it first started happening.

If I zoom in slightly and force the button for “Redo search in map” to appear, clicking on that will bring up the pins.

1 Like

Can you please provide a specific taxon that consistently does this, as well as a screenshot of what you are seeing?

Just went to the first one I could think of… Latrodectus katipo, used “More - Taxa info” to get to it, and when I clicked the “View All” it worked as expected, ie it zoomed to the range of the obs and placed pins. I tried a couple other taxa that I know it happened on, and same story.

I also get to the taxa page sometimes by being in an observation, and clicking the taxa name in an identification. So I tried that with Latrodectus katipo and the bug is repeatable with that path

via “Observation - Taxa in an ID - View All”:

via “More - Taxa info - View All”:

Hmm, I’m not able to replicate, using iNat.NZ in either Chrome or FF. Can you open up the web console and take a screenshot? there might be some info there that could help us diagnose this.

on chrome, the only “console” in the options I can find is a blank thing in the developer tools… I’m guessing I am in the wrong place… how do I open the console?

View > Developer > Javascript Console. It opens up the console on the page. If there are errors, they get noted in the the console. If nothing’s there, then it wont be helpful.

right place then… no error messages…

I didn’t have a view menu entry…

but under “More tools - Developer Tools”:

there is a console:
image

is the “10 hidden” relevant?

Looks like you did the right thing, bummer there’s nothing there.

Well, i’m curious if anyone else is noticing this behavior.