Observers, species, and other stats not showing on Explore, maps, taxon pages, etc

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Some taxa show “No Observations” under the “Top Observer” section despite having many total observations. For example the genus Xylella has 63 observations but no top observer.

Most of the child taxa of Kingdom Bacteria show up this way, although Bacteria itself does show a top observer. Some members of Viruses show top observers and some do not. Archaea, Protozoa, and Chromista also seem to have many child taxa with the same issue.


I just noticed this with the page for small-flower pawpaws as well, and when I click on the leaderboard, I’m just taken to a blank list with nothing on it!

This seems to be a sudden system-wide problem. I just tried it with many taxa and got that result (Chrome browser). For instance, [Imperial Moth [Eacles imperialis] shows over 12000 observations, but the other tabs (species, identifiers, observers) show no numbers. I waited for two minutes but it was not a slow-load problem. Same for genus Neotoma, woodrats: 4578 observations, no other categories. Rose family, Rosaceae: 1,604,216 observations, no other categories. Girgensohn’s Peatmoss, Sphagnum girgensohnii, 752 observations, no other categories. Repeated tries, same result. It’s not happening for every taxon, though. Myotis lucifugus, Rudbeckia hirta, Fabaceae, etc fill in normally. I don’t see a pattern.


A variant on this problem: Smilax, (Greenbriers) shows only the “Species” tab blank.

I think the same system-wide problem is also affecting the maps, both at the observation:

as well as species page:

The problem persists for me even after waiting and refreshing the pages, and was also with other observations/taxa. Sometimes the local observation do load, but if you zoom out, they dissapear again.

I have to admit, I was already excited this morning to find a “new” genus for iNat only to find out, there is this map-problem :wink:

1 Like

Glad i’m not the only one experiencing this!

The species, identifier and observers stats are not showing when I only specify the place and taxon filter. This happens on desktop as well as mobile browsers

They will show up if I add a user id filter


Yeah I’m having this same issue as of a couple hours ago - I can’t use explore to see what species are found in an area, which I do a lot. It’s really annoying.

1 Like

I can confirm the same. I’m using the web version of iNat, and I see all observations but not the species, identifiers or observers pages.
Edit: It seems to be able to show smaller number of species but not a large number.

Might be related to other apparently database-related problem I’m experiencing today: my dynamic lifelist does not load:

Below is the error msg from Firefox and same behavior observed on Chrome. I’m on MacOS 11.5.2.

1 Like

I’m experiencing this too (both Android app and desktop site)

I’m having the same problem right now (both on mobile and desktop)

Me too. Chrome. Desktop
No results

I merged separate bug reports into a single topic.

there was another topic before these:

Now that you mention the maps, I noticed yesterday while doing Identifications that some of the location maps for observations would just show the one observation, not any others nearby as usually show. Sometimes the surrounding points would fill in after a wait, but sometimes they wouldn’t. I kept thinking it was showing the observation as way out of range for the species! But it wasn’t.

same thing has been happening to me all day, I managed to get those tabs to appear by specifying an end date for the date observed filter

Thanks for reporting - I think these API issues should be fixed now. We upgraded the API yesterday and that introduced some errors when trying to read cached data. I think I found the problem and I’m no longer seeing errors in the logs or in my testing. Please let me know if there are URLs that are still not returning results.


did that fix everything reported in the thread? one of the issues noted in the thread was the species and observer counts not coming up on the Explore page. that still seems to be an issue, as far as i can tell: