Imported photos from iPhone won't upload from macbook

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): website

App version number, if a mobile app issue (shown under Settings or About): n/a

Browser, if a website issue (Firefox, Chrome, etc) : safari

URLs (aka web addresses) of any relevant observations or pages:
post similar to this issue:

Screenshots of what you are seeing:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
The last week or so, ive had an issue when uploading bulk observations onto the iNat site. my usual method is the same as these steps, except without the photo failing to load in.

here are the steps that lead me here:
Step 1: take photo on iPhone

Step 2: airdrop photo to MacBook

Step 3: convert the photo from HEIC file to PNG (also had same issue with JPEG)

Step 4: drag the photo from folder on my desktop to inat uploader (using the ‘choose files’ option leads to the same issue)

Step 5: wait for the metadata to load… which usually takes a couple seconds max per photo. however, it never loads in, and then the images are replaced with a red exclamation point.

As I said before, ive tried converting to different file types (png vs jpeg), as well as selecting through the site vs drag and drop. uploading the same photos through the inat iPhone app works fine, but when you have a lot of photos, its a lot more tedious.

any help appreciated!

edit: I looked in the metadata, and like the issue in the link above, the photos are indeed HEIF files even though ive converted them. Perhaps not solvable by inat in this instance either, then. Just weird that it started happening all of a sudden when this process has worked for years!

If your process has worked for years, I probably won’t be able to help, but for what it’s worth, my “tried-and-true” process is still working as of today, so let me mention a couple of things. First, I’ve never had a problem with JPEG so I recommend that.

I don’t know how you’re converting photos but that seems to be an important step. I use the Photos app on MacOS, which has always worked well for me. Based on other comments and threads, drag-and-drop from the Photos browser to the iNat uploader may or may not work.


Ah, so that’s where the pesky HEIC photos I get from customers are coming from!
I’ve had absolutely no luck using “save as” to convert them to other working formats. It’s not frequent enough in my case to warrant digging up a batch converter for them, so I usually just screenshot them in order to upload to our system. (Note that will result in lower resolution than the original file, however.)

I use Preview to convert the photos- I just select several at a time and ‘export…’.

I may just use Photos to convert them, but it’s a bit less convenient since my photos library/app is on an external drive. thanks for the tips!

screenshotting also changes the photo’s date and time, which is a bit tedious to manually fix for lots of photos. i’ve definitely done this in a pinch, though!

I haven’t done it but I’m pretty sure you can use the Photos app on MacOS with an external drive.

Actually now I’m a bit confused. Step 2 above doesn’t mention an external drive. Also, why don’t you use a cable instead of airdrop? That could be part of the problem.

Your mileage may vary but I connect my iPhone to MacBook with a cable and then use iTunes to import photos into the Photos app. After cropping (if necessary), I use the Export command in the Photos app to create the JPEGs that ultimately get uploaded to iNaturalist. After uploading, I delete the JPEGs.

I use the same process as you when using photos taken on my iPhone and I’ve not had this issue. Once the phone pictures are on my Macbook - I either drag them into photos and then back to a folder for uploading or I use quick action - convert file directly on the phone file in the folder. And whether jpeg or png it’s always been ok.

As you say - you’ve done this for years also so maybe some file corruption or similar - maybe look on some mac forums and see if anyone else has a problem with files failing to convert properly.

1 Like

I’m just transferring photos via airdrop from my phone to my laptop. no photo library involved. they just go into a desktop folder.
I do it this way because then I don’t need to dig out a cable, but maybe I’ll try with a cable.

You can change the photo format on your iPhone to JPG, and never worry about this again…. Plus, Android and PC users you send you photos to will be able to see them!

1 Like

I just airdropped an HEIC photo from my iPhone to my Macbook, then used Preview to Export as a jpeg and the uploader seemed to handle it fine. Here are the settings I used when exporting to jpeg using Preview:


this is exactly what I do! I bet it is something on my end, then. thanks for looking into it. I’ll troubleshoot more tomorrow.

1 Like

found a workaround. instead of batch-converting the images with the “file” > “export selected images…” method, I found that it consistently works to select the heic images, right-click, go to “quick actions” > “convert images”. this consistently seems to actually change the image metadata/file to jpeg instead of just adding .jpeg to the file name.

while messing with this I found that some of the images did get converted correctly with my original method, but I can’t figure out what they have in common and why they didn’t all do the same thing. macOS continues to be a hot mess.

thanks again for all the suggestions and troubleshooting, folks!