A different HEIC question

Hi all!

So i know that multiple people have already requested support for HEIC file uploading here, and that that is being discussed. Not trying to rehash that!

However I have a different conundrum related to HEIC files that I wonder if anyone has experienced or can explain.

Like many others, I experienced as an unfortunate side effect of upgrading to a new iPhone the sudden uselessness of my usual method of uploading photos to the iNat site. This has been devastating, for while I can still add observations directly from my iPhone using the app, it takes MUCH, MUCH longer than doing the batch uploads with dragging and dropping pictures on my computer that I was used to doing. Like, it used to take me maybe 10 minutes to get all my observations up after an outing. Now it can take about an hour :tired_face: It’s awful. But I’ve just been trying to slog through it in hopes that HEIC support for the website was just around the corner.

Now onto my specific issue. Some weeks back, I don’t remember exactly when but it must have been around late April, I noticed that for the first time I was able to drag and drop some HEIC files from my computer into the iNat uploader. HOORAY! It seemed as though HEIC support had come to the iNat site!

But wait! I found that SOME of my HEIC photos would upload, and then some of them would not. Hmm. I figured maybe since it seemed like a new thing being rolled out, maybe it was buggy.

But what I realized was even weirder.

So what I’ve found is that after I move all my photos from my phone to my computer, if I let enough time pass, they will start to work as uploads on the iNat site. I can’t explain it, but I have experienced it a number of times now. For example, let’s say I move a bunch of photos from my phone to my computer on Monday. If I immediately then try to upload them to iNat from my computer, none of them will work, I’ll simply get errors for all of them. BUT if I wait UNTIL THE NEXT DAY, some of the photos WILL START TO WORK! Even weirder, I know that it somehow has to do with time passing, because the first ones to start to work are the ones that I moved first from my phone to my computer. What I’ve found is I’ll let time pass, then try uploading my photos from the previous day. Usually some number will work, and then I’ll hit a wall after which they don’t work, and then I have to wait and let more time pass and eventually the later ones will start to work too.

Can ANYONE explain this?? I am so utterly baffled, and if anyone could help me figure this out, or has any tips for something I can do differently so that I can upload the photos to iNat right away, I’d be really grateful. Has anyone else experienced this??

If it matters, the phone is an iPhone 13 Pro, and the computer is a 2020 MacBook Pro running MacOS Monterray version 12.4.

I am attaching a screenshot just to illustrate. The below screenshot shows the results of trying to drag and drop two different photos from my Mac photos app into the iNat website uploader. These pictures were taken on the same day, have the same technical specs, and were moved from my phone to my computer in the same batch. The ONLY difference is that the picture on the left was moved earlier in the batch. It has therefore developed the magical power of being accepted by iNat, whereas the photo on the right still has to wait some indeterminate amount of time before it will work.

Thanks for listening and thanks for any help or ideas!

3 Likes

I don’t know why the time would matter, but you can set photos to convert to jpegs on transfer from a phone, so maybe this is part of what’s happening? Can you check the format of the files that you are uploading that work to verify if they are heic or jpeg?

You can also bulk convert heic to jpg on macs using preview and the photos app (or so I’ve read - don’t own one myself).

Thanks for the response. They are HEIC files.

Here’s a screenshot of info of one of the photos. This is the info for the WORKING photo from my upload screenshot above.

1 Like

maybe just bulk convert them with something like this?

Thanks! I will check this out.

Definitely seems worth looking into an option like this if it’s going to take a while longer for HEIC support to come to the site. Still baffled by being able to upload the photos after time passes, though!

If you’re comfortable with a command line interface (CLI) ImageMagick may work for converting a bunch of HEIC files at once:

mogrify -format jpg *.heic

Note: Haven’t tested this myself.

1 Like

Thanks for the suggestion! I’m not familiar with this but will look into it.

it looks like the one that successfully loaded loaded as a .jpg file.

this observation seems to have been taken at 3:02PM. can you go to your Mac and screenshot the details of the photo that was taken at 3:02PM to check to see what kind of file it is on the computer?

(the screenshot you included in an earlier post is of an image taken at 3:07PM. so i’m guessing that’s a different observation)

i don’t have a Mac, but this seems like a easy way to convert using built-in stuff on MacOS: https://www.howtogeek.com/398927/how-to-convert-heic-images-to-jpg-on-a-mac-the-easy-way/.

Hi pisum, thanks for looking into this for me!

So a couple of things. First of all, weirdly, none of the shots I took of this katydid (I usually take a few shots of whatever I’m looking at) show on my computer as being taken at 3:02 pm. Which is strange, because when I look at my phone, they do indeed all show as being taken at either 3:02 or 3:03. On my computer, a few of them are shown as 3:03 pm, and a few others are shown as 3:07 pm. Which can’t be right, because I took them all at the same time, so there’s no way they could have actually been 4 minutes apart. Not sure what’s going on there, but for some reason my phone seems to have the correct time stamps and my computer has them incorrect.

Second and more importantly, I’m pretty sure that I uploaded the actual observation of that katydid from my phone app. I get very frustrated waiting for the images files on my computer to work in the iNat site uploader, which in my experience can take anywhere from 24 to 48 hours from the time I move them onto my computer. So I often will uploaded a few observations from an excursion from my phone, especially if I’m particularly jonesing to find out the identification of whatever I was looking at. Then, I wait for whatever magical process occurs to upload the rest of my observations from my computer, so that I can do it in a much less time consuming fashion.

So I THINK the observation of the katydid was from the phone app. Later I was playing around with things as I was waiting for the majority of my photos from that day to start working, and that’s when I screenshotted the two side-by-side working and not working photos. But I don’t think I actually put up any observations then.

HOWEVER, I can tell you for sure that I uploaded this observation from my computer today: https://www.inaturalist.org/observations/123091705

And here is a screenshot of the photo info for the first photo in this observation:

As you can see it is stored as an HEIC file, as all the ones stored on my computer are. So if there is a file type transition happening, it must be something the iNat site itself is doing. I can’t imagine why that starts working only after some amount of time has past, and not right away?

can you go to this webpage (https://www.inaturalist.org/photos/208486829), and take a screenshot of it that includes the filename of the photo that was uploaded? (filename should show up in the metadata section of the page on the right side.)

Here it is!

So here I can see the file type is given as JPEG. But as seen in the screenshot I sent in my last reply, this photo is still an HEIC on my computer. So I can only guess the iNat uploader is converting them? But only after they’ve been on my computer for an indeterminate amount of time?

does it make a difference if you go to the web uploader page and upload the photo by dragging it onto the uploader page vs selecting it from a file chooser?

Just checked this. So, if I try to use the file chooser, it won’t even let me select any of my photos for uploading, because they’re HEICs which I guess the uploader doesn’t accept. So they’re all grayed out. Even the ones that I successfully uploaded by dragging and dropping earlier today.

ok. 2 final questions:

  • what’s the general process you’re using to copy your photos from your phone to your computer?
  • on your Mac specifically, are you backing up your photos to a cloud service like iCloud or Google Drive?

I used to primarily use AirDrop (a Bluetooth method that works between Apple devices) to move photos from my phone to my computer. Recently I started doing it wired, plugging my phone into my computer and importing them using the Mac Photo app. Either way has been the same result in terms of how things act when I try to upload to iNat.

I am not using any cloud service. These photos are all directly on my hard drive.

hmmm… i’m not sure what to make of this. when i try to upload a .heic file via drag+drop, i don’t even get as far as you did:

there’s no observation “card” created in my upload page. it just fails with an error message.

it seems like the Mac (not iNat) must be doing some sort of conversion on the fly when you try to upload your photos. but there might be some sort of weird timing thing / race condition where that conversion isn’t complete before iNat attempts to use the file.

there’s another thread where @sullivanrabbit proposed this workflow for exporting photos (https://forum.inaturalist.org/t/random-iphone-photos-wont-upload-to-inaturalist-from-macbook/17857/3), which seemed to solve the problems that the original poster on that thread was having. the problem described there sounds similar to what you’re describing here. so you could try that workflow and see if it solves your problems, too.

So perplexing! The mystery continues! Really appreciate you trying to get to the bottom of this!

I will give the method in the other thread a try.

One other idea, just something that entered my head although I think your suggestion about the Mac doing some sort of on the fly conversion seems the most plausible. But just raising as another idea, could it have anything to do with the browser I’m using? I’m working in Firefox.

i don’t think it’s browser-related. i think the Mac or the Photos app on the Mac are the 2 likeliest suspects for doing the on-the-fly conversion.

i tried loading my file via a Chromium-based browser and via Firefox, and it didn’t make a difference. neither browser seemed to attempt to do a file conversion that allowed me to get the observation cards that you got in your upload.

Note - i’m no expert with these but just some quirky things that could maybe be checked:
Could it have to do with any the following:

  1. colorspace - are your heic files in a less common colorspace and when you open them on your computer or such, perhaps your image viewer auto-converts to display, or something?
  2. are some of your heic files ‘live photos’ and those are the ones not working?
  3. how iphones can take multiple images in a series, and then select one to display, do you need to select ones to save first

Got it. Yep I guess that seems the most likely at this point! Definitely not what I was expecting. I’m so curious if anyone else with a Mac is experiencing the same thing!