In "Explore" I can't select "Africa" as a continent

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome or Firefox

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Select “Explore” from top menu

Step 2: in “Species”, enter any taxon. In “Location” enter Africa. None of the presented options is the African continent. They are all small localities.

Step 3: Click orange “Go” button. This used to take me to Africa, but doesn’t any more.

So what can I do?

The Location entry that you are using and the one in the Filters dropdown menu pull from different databases. All continents are available under Filters but not in the default location bar.


You can also just type “Africa” and hit Enter/Return. It won’t show up in the dropdown but it will work.


Use the filter for Africa.
That is how I do it.

Filters are (sensible) iNat places.
Location comes from the great Google, which doesn’t know Africa.