Inaccurate locations from Seek

@tiwane i tried [posting to iNat from seek] out a couple times just to see how it worked. I obviously wouldn’t be using it to make many observations (auto upload, but it does make sense on there). But i did notice one issue. The GPS location seemed wildly off, like two miles off. I know these are meant to be for casual users who would probably switch to the main app if they wanted to upload lots, so it probably won’t affect that much data. But it might be worth slapping a big uncertainty circle on the Seek observations. I’ll try it out a few more times to see how it works in other settings.

I am glad you can post to inat though, i’ve got my neighbors into seek and maybe i can use it as a gateway :)

4 Likes

I was initially pretty excited about this addition, but I encountered the location problem, too. I have long since had trouble with Seek’s location data. I often use it to get insight into a completely unknown plant, but I always have to be careful not to upload any photos to iNat that I took with the Seek app. Sometimes the location will be off by a couple of miles.

I uploaded two plants using Seek the same day as I got the update. Both had incorrect locations. It seemed to locate one of the plants in the place where I got a WiFi signal, more than a mile from where I hit “upload.”

I will try to investigate this more tomorrow.

1 Like

interesting, one of my seek observations also popped up the last place i got wifi, so that might be a good lead on a bug.

1 Like

Ok, I have scrapped the WiFi idea. I took three pictures and uploaded them to iNat via the Seek app today. All three photos were taken at different locations about a half mile apart. Seek incorrectly identified the location of all three photos, and–get this–the location of all three photos was in the same wrong place. The incorrect location was about 300 yards from the first photo 1/2 mile from the second, and a mile from the third.